Macromedia Flash 8

Aus Debacher-Wiki
Wechseln zu: Navigation, Suche

Flash ist eine Animationssoftware für Webanwendungen, die lange Zeit von der Firma Macromedia entwickelt wurde. Inzwischen hat Adobe diese Firma übernommen, von daher steckt auch die Software in einem gewissen Umbruch. Zur Zeit (März 2007) befinden sich die Webseiten von Macromedia bzw. Adobe stark im Umbruch auf eine neue Version.

Wer also die Software testen möchte sucht momentan besser nach einer anderen Download-Quelle z.B. Chip Online. Die Software kann ohne weitere Einschränkungen für 30 Tage getestet werden. Nach Ablauf der 30 Tage kann die installierte Version über einen Registrierschlüssel dauerhaft aktiviert werden.

1. Die Oberfläche

Bei Start von Flash ergibt sich folgendes Bild:

Flash-1.PNG

Hier sieht man im Hintergrund schon die Arbeitsfläche und im Vordergrund einen Dialog. Hier wählt man entweder Öffnen, wenn man eine vorhandene Datei bearbeiten möchte, oder Neu erstellen -> Flash Dokument, wenn man neu beginnen möchte. Startet man mit einem neuen Dokument, so ergibt sich folgende Arbeitsfläche.

Flash-2.PNG

Der Aufbau der Oberfläche ist auf den ersten Blick recht unübersichtlich, aber schnell beschrieben:

  • Am linken Rand des Fensters findet sich die Werkzeugpalette u.a. mit den Zeichenfunktionen.
  • Rechts neben der Werkzeugpalette folgt das Dokumentfenster mit der Bühne. Jedes geladene Dokument besitzt sein eigenes Dokumentfenster.
  • Unterhalb des Dokumentfensters und rechts daneben befinden sich mehrere Eigenschaftsleisten.
    • Diese Leisten sind von ihrem Inhalt her kontextabhängig, zeigen immer die Funktionen für das aktuell ausgewählte Element.
    • Jede dieser Leisten lässt sich öffnen bzw. schließen, jeweils durch einen Klick auf das schwarze Dreieck am linken Rand der Titelzeile.
    • Die Position der Leisten lässt sich verändern, so können z.B. alle Leisten unterhalb des Dokumentfensters auch nach Rechts verschoben werden bzw. umgekehrt.
    • Eine besondere Erwähnung findet die Leiste Bibliothek, hier hinein kann man Objekte für eine spätere Verwendung laden oder kopieren.

Alle Leisten und die Werkzeugpalette lassen sich verschieben, dazu muss man nur mit der Maus an der doppelten gepunkteten Linie anfassen. Die Leisten lassen sich dann an verschiedenen Positionen wieder einklinken, die möglichen Positionen werden beim verschieben durch schwarze Rechtecke kenntlich.


2. Zeichnen und Malen mit Flash

Eine der wichtigsten Eigenschaften von Flash sind die Animationen. Bevor man aber Elemente animieren kann muss man sie erst einmal zeichnen. Im ersten Schritt wollen wir uns daher nur mit den entsprechenden Funktionen beschäftigen. Um die Übersichtlichkeit zu erhöhen schließen wir alle Leisten außer Eigenschaften | Filter | Parameter. Auch die Zeitleiste im Dokumenten-Fenster schließen wir erst einmal, indem wir auf das Wort Zeitleiste links oben im Dokumentfenster klicken.

Es sollte sich folgende Ansicht ergeben:

Flash-3.PNG

Im Eigenschaftsfeld sehen wir nun die Eigenschaften der Bühne. Die Bühne ist der weiße Zeichenbereich innerhalb des Dokumentfensters. Die Größe ist mit 550x400 Pixel vorgegeben, was aber jederzeit (nahezu) beliebig verändert werden kann. Elemente außerhalb der Bühne sind in der Animation später nicht sichtbar. Die Hintergrundfarbe ist auf Weiß eingestellt, lässt sich aber durch einen Klick auf das entsprechende Feld verändern. Die weiteren Einstellungen sollten erst einmal belassen werden.

Im Bereich der Bühne kann man nun beliebig zeichnen bzw. malen, dazu benutzen wir einige Elemente aus der Werkzeugpalette.

2.1. Das Linienwerkzeug

Das Linienwerkzeug ist über das erste Icon in der dritten Reihe der Werkzeugpalette zu erreichen. Geht man mit der Maus über das Icon, so wird die Bezeichnung angezeigt und auch die Taste "N", über die diese Funktion per Tastatur erreichbar ist. Sehr viele der Funktionen sind über einfache Tastendrücke erreichbar.

Flash-4.PNG
Wählt man dieses Werkzeug aus, so kann man, wie aus vielen anderen Anwendungen heraus bekannt, Linien ziehen. Diese Linien lassen sich in Farbe, Breite und Linientyp an die individuellen Bedürfnisse anpassen. Leicht übersehen kann man die beiden Icons unten in der Werkzeugpalette, in der Rubrik Optionen, unterhalb der Farbeinstellungen.

Das linke Icon Objektzeichnung dient dazu zwischen zwei grundlegenden Modi umzustellen, nämlich dem Malen und dem Zeichnen. Im Prinzip ist es so, dass beim Malen eine Ansammlung von Punkten entsteht, beim Zeichnen ein Objekt. Für den Betrachter sind die Unterschiede nicht zu erkennen, für manche Bearbeitungsschritte macht es aber einen großen Unterschied, ob eine Linie vom Typ Form ist, also eine Ansammlung von Punkten, oder ein Zeichenobjekt. Das rechte Icon zeigt einen Magneten und ist mit An Objekten ausrichten beschriftet. Wenn dieser Modus eingerichtet ist, dann hilft Flash dabei geschlossene Formen zu zeichnen, indem die Linienpunkte an vorhandenen Objekten ausgerichtet werden.

Linien, egal von welchem Typ, lassen sich auch später noch weiter bearbeiten. Sehr wichtig sind die Funktionen zum Transformieren.

Flash-5.PNG

Das linke Icon in der zweiten Reihe der Werkzeugpalette ist mit Frei transformieren beschriftet. Wenn man diese Funktion aktiviert und eine Linie auswählt, dann kann man diese drehen, skalieren und Verzerren. Die Auswahl der jeweiligen Operation erfolgt über die neuen Icons in der Werkzeugpalette oder durch Auswahl der passenden Angriffspunkt mit der Maus. Man muss beim Arbeiten mit der Maus einfach auf die sich verändernden Cursor achten.

2.2. Das Stiftwerkzeug

Die Bedienung dieses Werkzeuges ist auf den ersten Blick recht ungewöhlich. Im einfachsten Fall ist es so, dass man nach der Aktivierung des Werkzeuges einfach auf die Eckpunkte des Linienzuges klickt. Jeder Mausklick führt zu einer Linie vom letzten Punkt zum aktuellen Punkt. Wenn man stattdessen die Maus zieht, dann werden Kurven erzeugt, deren Krümmung durch das Ziehen verändert wird. Will man die Figur schließen, so muss man mit der Maus in die Nähe eines der vorhandenen Pfadpunkte gehen und darauf achten, dass neben dem Cursor ein kleiner Kreis auftaucht. Wenn man jetzt klickt, dann wird die Figur geschlossen und ggf. farbig gefüllt.

2.3. Ellipsen-, Rechteck- und Polystern-Werkzeug

Ellipsen- und Rechteck-Werkzeug bieten keine Überraschungen. Mit diesen Funktionen lassen sich flächige Objekte erstellen, die eine Füllung und einen Rand besitzen. Hält man beim Ziehen die Shift-Taste gedrückt, so entstehen Kreise bzw. Quadrate. Bei den Rechtecken kann man vor dem Zeichnen auch die Abrundung der Ecken einstellen, dazu dient die Funktion Eckenradius innerhalb von Optionen in der Werkzeugpalette.

Etwas versteckt ist das Polystern-Werkzeug. Um es zu erreichen muss man mit der Maus längere Zeit auf das Icon für das Rechteck-Werkzeug drücken. Es öffnet sich dann eine Auswahl, in der auch dieses Werkzeug zur Verfügung steht.

Flash-6.PNG

Mit dem Werkzeug kann man sowohl Polygone, als auch Sterne zeichnen. Die Einstellung erfolgt über den Button Optionen in der Eigenschaftsleiste.


2.4. Freihandwerkzeug, Pinsel und Radiergummi

Das Freihandwerkzeug dient zum freihändigen Zeichnen mit der Maus. Auch hier kann man wie beim Linienwerkzeug zwischen Form und Zeichenobjekt umschalten, durch das entsprechende Icon innerhalb von Optionen in der Werkzeugleiste. Innerhalb von Optionen gibt es eine weitere wichtige Auswahl. Das zugehörige icon zeigt einen Linienzug. Wenn man darauf klickt, dann kann man zusätzliche Funktionen aktivieren:

  • Begradigen dient dazu ungenaue Linienführung auszugleichen. Wenn man also freihändig ein Rechteck gezeichnet hat, dann kann Flash daraus ein richtiges Rechteck machen.
  • Glätten beseitigt Unebenheiten in der Linienführung.
  • Freihand verändert den Linienzug nicht.

Das Pinselwerkzeug dient auch dazu freihändig zu zeichnen, nur dass Füllungen erzeugt werden und keine Konturlinien.

Sehr ähnlich zum Pinsel arbeitet auch das Radiergummi, nur das es Teile der Zeichnung entfernt.


2.5. Das Textwerkzeug

Die Einstellmöglichkeiten für dieses Werkzeug sind vielfältig. Am Anfang kommt man aber gut mit der Auswahl von Schriftart und Schriftgröße aus. Es ist wichtig zu wissen, dass man jede der verfügbaren Schriften bedenkenlos einsetzen kann, dass Flash die Form mit in die Ausgabedatei schreibt. Die Schrift muss also nicht auf dem System installiert sein, auf dem die Animation später abgespielt wird.

Ganz links in der Eigenschaftsleiste findet sich die Auswahl zwischen den unterschiedlichen Texttypen:

  • Statischer Text ist Text, der einfach als solcher in der Animation auftaucht.
  • Dynamischer Text kann innerhalb von ActionScript verändert werden
  • Texteingabe erzeugt ein Eingabefeld für Formulare.

In der Regel werden wir also erst einmal mit statischem Text arbeiten.


3. Einfache Animationen

Zu den wichtigsten Funktionen von Flash gehören die Animationen. Eine einfache Animation besteht aus einer Folge von Einzelbildern innerhalb der Zeitleiste. In diesem Abschnitt wollen wir in Flash schrittweise einen einfachen Sonnenaufgang realisieren.

<flash>file=Sonne1.swf|width=550|height=400|bgcolor=#c0c0c0|scale=exactfit|quality=high|menu=true</flash>


3.1. Die Zeitleiste

Über einen Klick auf das Wort Zeitleiste im Dokumentfenster lässt sich die Zeitleiste einschalten, falls sie nicht vorhanden ist.

Flash-7.png

Die Zeitleiste verwaltet die einzelnen Bilder einer Animation. In der Standard-Ansicht geht die Skala etwa bis zu 60 Bildern. Diese Bilder werden üblicherweise mit einer Rate von 12 Bildern pro Sekunde (12 bps) abgespielt, so dass die 60 Bilder 5 Sekunden Animation ergeben. Die Bildwiederholrate lässt sich in den Eigenschaften der Bühne verändern, höhere Raten ergeben flüssigere Animationen, stellen aber entsprechend höhere Ansprüche an die Rechner-Hardware und führen zu größeren Flash-Dateien.


3.2. Ebenen

Am linken Rand der Zeitliste ist die Ebenen-Verwaltung angesiedelt. Es handelt sich bei den Ebenen um so etwas wie Folien, die in der Animation übereinander gelegt werden. Für jedes animierte Objekt ist eine eigene Ebene notwendig. Statische Objekte sollen sich in eigenen Ebenen befinden.

Von den (nahezu) beliebig vielen Ebenen ist immer eine die aktuelle Ebene, zu erkennen am Stiftsymbol. Über die anderen Icons lassen sich einzelne Ebenen ausblenden, oder gegen Veränderungen sperren. Das Ausblenden betrifft aber nur die Darstellung zur Bearbeitung, nicht die fertige Animation.


3.3. Symbole

Für den Sonnenaufgang benötigen wir die Sonne, einen gelben Kreis. Dieser Kreis soll nun im Laufe der Animation von Bild zu Bild etwas weiter nach Rechts und nach Oben verschoben werden. Wenn wir das über 60 Bilder machen, dann haben wir 60mal den Kreis gezeichnet. Das führt zu einem relativ hohen Speicherbedarf. Geschickter ist es Elemente, die auf mehreren Bildern auftauchen zu Symbolen zu machen. Symbole werden über die Bibliothek verwaltet und können sehr effektiv mehrfach benutzt werden.

Zum Erstellen von Symbolen gibt es zwei Möglichkeiten.

  • Man kann über das Menü Einfügen -> Neues Symbol gehen,
  • oder über Modifizieren -> In Symbol konvertieren eine vorhandene Zeichnung umwandeln.

Für unser Beispiel beginnen wir damit einen gelben Kreis im linken mittleren Bereich der Bühne zu zeichnen. Den Kreis wählen wir aus und gehen dann über das Menü Modifizieren zu In Symbol konvertieren. Es öffnet sich ein neuer Dialog.

Flash-8.png

Hier geben wir als Namen Sonne an und als Typ Grafik. Über Registrierung lässt sich der Bezugspunkt wählen, wichtig für Animationen an Pfaden. Sowie wir auf Ok klicken taucht die Sonne in der Bibliothek auf und im aktuellen Bild ist die Sonne schon als Symbol eingebunden.


3.4. Schlüsselbilder

Die Bilder eines Flash-Filmes, auf denen sich etwas ändert werden als Schlüsselbilder bezeichnet. Zwischen zwei Schlüsselbildern bleibt die Darstellung unverändert. Im einfachten Fall könnte man also nach einer Folge von Bildern das Objekt löschen, verändern oder durch ein anderes Objekt ersetzen.

Wir gehen jetzt auf Bild 30 und klicken auf das leere Bild in der aktuellen Ebene und gehen dann über das Menü Einfügen -> Zeitleiste -> Schlüsselbild. Flash fügt nun an dieser Stelle ein neues Schlüsselbild ein, wobei alle Objekte des bisherigen Schlüsselbildes auch vorhanden sind. Falls man die nicht haben möchte kann man sie hier wider löschen oder hätte gleich Leeres Schlüsselbild beim Einfügen auswählen können.

Wenn man sich jetzt über Datei -> Vorschau für Veröffentlichungen -> Flash das Video einmal anschaut, dann dürfte eine gewisse Enttäuschung da sein. Die Sonne bleibt die ganze Zeit an der gleichen Stelle und springt dann einmal kurz auf die erhöhte Position. Aber genau das haben wir so eingestellt. Über die Bilder 2 bis 29 bleibt die Situation von Bild 1 bestehen und nur in Bild 30 bekommt die Sonne eine neue Position.


3.5. Tweening

Bei einer Bewegung ändert sich von Bild zu Bild die Position des Objektes gleichmäßig. Da das über viele Bilder nur recht mühsam zu realisieren ist bietet Flash eine Hilfe in Form des Tweening.

Um das Tweening zu aktivieren klicken Sie auf das Kästchen des ersten Bildes in der richtigen Ebene.

Flash-9.png

In der Eigenschaftsleiste sollte nun die Einstellmöglichkeit Tween auftauchen. Wählen Sie hier Bewegung aus, so kümmert sich Flash alleine um alle Zwischenbilder. Sie können jetzt auf ein beliebiges Bild in der Zeitleiste klicken, die Sonne hat jeweils eine andere Position. Über die Vorschaufunktion kann man sehr schön die Bewegung verfolgen.

Wir können beim Tweening aber nicht nur die Position des Objektes verändern, sondern auch seine Größe und Farbe. Gehen Sie dazu erst einmal wieder auf Bild 1 in der aktuellen Ebene, klicken die Sonne an und wählen in der Werkzeugpalette Frei transformieren (oberhalb des Linienwerkzeuges) aus. Nun können wir die Sonne etwas vergrößern, sie wirkt ja am Horizont auch immer etwas größer.

Auch die Farbe wollen wir noch anpassen, am Horizont erscheint die Sonne immer etwas rötlich. Also gehen wir wieder auf Bild1 der Ebene, aktivieren das Auswahlwerkzeug und klicken auf die Sonne. In der Eigenschaftsleiste sollte jetzt Farbe auftauchen. Hier stellen wir von keine auf Farbton um und wählen einen passenden rötlichen Ton aus. Über den Regler hinter der Farbangabe stellen wir das Mischungsverhältnis ein. Entweder nehmen wir als Farbe Rot und dann ein Mischunsgverhältnis von 50%, oder gleich die gewünschte Mischfarbe und dann 100%.

Nun geht die Sonne so auf, wie wir uns das vorstellen.


3.6. Arbeit mit Ebenen

Was jetzt an der Animation noch fehlt ist der Horizont. Der Horizont kann ganz einfach aus einem blauen Rechteck für den Himmel und einen grünen Rechteck für die Erde bestehen. Der Himmel muss hinter der Sonne liegen und die Erde vor der Sonne.

Wir fügen also erst einmal zwei neue Ebenen hinzu und benennen die eine Himmel und die andere Erde. Bei der Gelegenheit können wir auch die Ebene mit der Sonne in Sonne umbenennen. Auf der Ebene Himmel füllen wir die gesamte Bühne mit einem himmelblauen Rechteck und auf der Ebene Erde füllen wir die untere Hälfte der Bühne mit einem grünen Rechteck. Dummerweise liegt nun auch der Himmel vor der Sonne. Das Problem lässt sich aber lösen, indem man die Himmels-Ebene mit der Maus unter die Sonnen-Ebene zieht, dazu fasst man das Rechteck mit dem Namen.


Flash-10.png

Das Bearbeiten der Elemente in der Sonnen-Ebene ist nun etwas mühsamer, weil immer das grüne Rechteck davor liegt. Zur Erleichterung kann man in der Ebenenverwaltung diese Ebene ausblenden, dazu dient das Icon mit dem Auge, oder alle Objekte ungefüllt als Kontur anzeigen lassen, dazu dient das Icon mit dem farbigen Rechteck. Die Farbe im Rechteck ist auch diejenige, mit der die Kontur angezeigt wird. Auf den Export der Animation haben diese Einstellungen aber keinen Einfluss.


3.7. Einbinden der Animation in eine Website

Wenn man die Animation über Datei -> Veröffentlichen fertigstellt, so erzeugt Flash zwei Dateien:

  • Die eigentliche Flash-Datei mit der Endung .swf
  • Eine HTML-Seite, die die Flash-Datei einbindet und die Endung .html besitzt.

Der entscheidende Teil im von Flash erzeugten HTML-Code sieht folgendermaßen aus:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"  
    codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" 
    width="550" height="400" id="sonne1" align="middle">
  <param name="allowScriptAccess" value="sameDomain" />
  <param name="movie" value="sonne1.swf" />
  <param name="quality" value="high" />
  <param name="bgcolor" value="#ffffff" />
  <embed src="sonne1.swf" quality="high" bgcolor="#ffffff" width="550" height="400" name="sonne1" align="middle" 
    allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

Hier taucht an zwei Stellen der Name der Flash-Datei auf. Einmal als Parameter im Object-Tag und einmal als Parameter im Embed-Tag. Genaugenommen tauchen alle Einstellungen doppelt auf, weil der Object-Tag mit classid eine proprietäre Erweiterung des Internet-Explorers unter Windows darstellt, die ActiveX voraussetzt. Andere Browser benutzen stattdessen den Embed-Tag. Der Internet-Explorer wertet also den Object-Tag aus und ignoriert den eingebetteten Embed-Teil. Alle anderen Browser ignorieren den Object-Tag, sehen nur den eingebetteten Embed-Tag.


4. Weitere Möglichkeiten des Tweening

Mit dem Bewegungs-Tweening haben wir bisher ein Objekt gleichmäßig vom Anfangs-Punkt bis zum Endpunkt bewegt. Flash bietet aber noch einige Möglichkeiten mehr, wie schon an dem Eigenschafts-Fenster zu sehen ist.

Flash-11.png


4.1. Beschleunigung

Im einfachsten Fall bleibt man bei der linearen Bewegung, beschleunigt das Objekt aber im Laufe der Bewegung, oder bremst es ab. Dafür ist die Einstellmöglichkeit Beschleunigung zuständig. Die Skala von -100 bis +100 ist hier etwas missverständlich. Etwas deutlich wird die Bedeutung dieser Werte, wenn man auf Bearbeiten... klickt.

Flash-12.png

Hier kann man sehen, dass am Anfang die Animation schneller abläuft und am Ende nahezu keine Veränderung mehr stattfindet. Bei negativen Werten für Beschleunigung verläuft die Kurve anfangs flacher, um dann am Ende entsprechend steiler zu verlaufen.

Wer den Animationsverlauf etwas komplexer gestalten möchte, der kann diese Kurve nahezu beliebig gestalten. Mit jedem Klick auf die Kurve richtet Flash einen neuen Punkt ein, dessen Position sich nahezu beliebig verändern lässt.

Flash-13.png

Im dargestellten, relativ extremen Beispiel, würde die Sonne zweimal fast bis zum Endpunkt gehen, dann wieder nahezu zum Anfangspunkt und erst dann zum Zielpunkt.

Der Kurvenverlauf beschreibt nur die Geschwindigkeit, wobei auch rückläufige Bewegungen möglich sind. Der zurückgelegte Weg bleibt aber immer die gerade Verbindungslinie zwischen Anfangs- und Endpunkt.


4.2. Animation am Pfad

Möchte man Objekte nicht auf direkter Linie vom Anfangspunkt zum Endpunkt bewegen, so bietet Flash die Möglichkeit der Animation am Pfad. Ein Pfad ist hierbei eine durchgezogene Linie die aber nicht geschlossen sein darf, weil sie einen eindeutigen Anfangs- und einen eindeutigen Endpunkt benötigt.

Der Pfad muss sich auf einer speziellen Ebene befinden. Zum Einrichten dieser Ebene achtet man darauf, dass die Ebene mit der Sonne aktiv ist. Dann erstellt man über das Menü Einfügen->Zeitlaste->Pfad die neue Ebene (man kann natürlich auch über das Icon Pfadleiste einfügen unterhalb der Zeitleiste gehen).

Flash-14.png

Die neue Ebene steht oberhalb der Ebene mit der Sonne und die Ebene mit der Sonne ist etwas eingerückt, was die Abhängigkeit verdeutlichen soll. Nun aktiviert man die Pfadebene und zeichnet eine Linie, wobei die Farbe beliebig ist, da diese Linie später in der Animation nicht zu sehen sein wird.

Nach dem Zeichnen der Linie wechselt man wieder in die Ebene mit der Sonne, geht zum ersten Schlüsselbild und positioniert die Sonne mit ihrem Bezugspunkt auf den Anfang der Linie. Das Objekt schnappt deutlich ein, vor allem wenn in der Werkzeugleiste die Option An Objekt ausrichten aktiv ist (dazu gehört das Icon mit dem Magneten).

Entsprechend verfährt man mit dem letzten Schlüsselbild un dem Endpunkt der Linie.

Flash-15.png

Die Sonne sollte jetzt dem Pfad folgen.

Als Pfad ist auch ein Kreis möglich, wenn man einen kleinen Trick benutzt. Dazu zeichnet man einen Kreis ohne Füllung. Dazu klickt man im Auswahlfeld für die Füllfarbe auf das Icon mit der diagonalen roten Linie. Wenn dieser Kreis gezeichnet und positioniert ist, dann wählt man das Radierwerkzeug und entfernt einen kleinen Abschnitt aus dem Kreis. Danach gibt es dann einen eindeutigen Anfangs- und einen eindeutigen Endpunkt.

Je kleiner die Lücke ist, desto weniger nimmt man in einer Animation den hier vorhandenen Sprung wahr.


4.3. Formtweening

Eine besondere Art des Tweening ist das Form-Tweening, bei dem eine Form in eine andere überführt wird. Der Effekt ist auch als Morphing bekannt. Für das Formtweening benötigt man zwei Zeichnungen, keine Symbole.

Im einfachten Fall zeichnet man in Schlüsselbild 1 ein Rechteck und in Schlüsselbild 30 einen Kreis, wobei sich auch die Farben und die Position unterscheiden dürfen. Aktiviert man nun in Schlüsselbild 1 das Formtweening, so wird das Recheck schrittweise in einen Kreis überführt.

Flash-16.png

Die resultierende Animation ist nicht immer ganz einfach vorhersehbar, dahinter stecken relativ aufwändige mathematische Verfahren. Man kann den Verlauf aber beeinflussen, indem man in beiden Bildern zugehörige Formmarken setzt, das sind Punkte die unbedingt aufeinander abgebildet werden müssen. Zum Setzen der Formmarken kommt man über das Menü Modifizieren-> Form-> Formmarken.

Relativ einfach zum machen sind Texteffekte wie der folgende.

<flash>file=Fh-haw.swf|width=300|height=200|bgcolor=#c0c0c0|scale=exactfit|quality=high|menu=true</flash>

Im ersten Schritt erzeugt man im Schlüsselbild 1 den Ausgangstext in der gewünschten Schriftart und Größe. Dann geht man z.B. auf Bild 30 und fügt ein Schlüsselbild ein. Flash kopiert den Text von Bild 1, der dann hier bearbeitet und verändert werden kann. Wir ersetzen das FH durch HAW.

Bei diesen Schlüsselbildern kann man das Tweening aber noch nicht aktivieren, dazu muss man erst die Texte in Zeicheobjekte teilen. Dazu wählt man nacheinander in beiden Schlüsselbildern den Text aus und wählt dann Modifizieren -> Teilen. Im ersten Schritt wird dabei der Text in die Buchstaben zerlegt, das langt noch nicht, man muss Teilen noch einmal anwenden, danach sind Zeichenobjekte entstanden, für die im ersten Schlüsselbild dann das Form-Tweening aktiviert werden kann.


Flash-17.png