OpenOffice-Calc

Aus Debacher-Wiki
Wechseln zu: Navigation, Suche


Status: angefangen

1. Tabellenkalkulation

Die Tabellenkalkulation führt auf vielen Rechnern ein Schattendasein. Oft wird sie benutzt, um tabellarisch Daten zu erfassen oder die Nutzung einer Datenbank zu umgehen. Sie wird z.B. gern eingesetzt, um Stundenpläne zu erstellen. Was für eine Verschwendung von Möglichkeiten.

Eine Tabellenkalkulation ist vor allem dann sehr nützlich und hilfreich, wenn man mit "Was wäre wenn" Problemen zu tun hat. Dazu gehören auch alle Berechnungen im Zusammenhang mit Zins- und Zinseszins. Einige der folgenden Beispiele werden sich damit beschäftigen.

1.1 Werkzeuge

Nahezu jedes Office-Paket verfügt seit Jahren über eine Tabellenkalkulation. Urahn aller Tabellenkalkulationen war das Programm Visicalc, welches 1979 für den Apple II erschien und auf viele andere Computersysteme portiert wurde. Recht bekannte Vertreter dieser Programmart sind (bzw. waren) Lotus 1-2-3 und Multiplan. Heute wird von unbedarften Computernutzern die Tabellenkalkulation mit Excel gleichgesetzt.

1.2 Für Umsteiger

Wie bei nahezu allen Programmkomponenten so ist der OpenOffice-Benutzer auch hier auf der sicheren Seite. Er kann eigentlich alle anderen Dateiformate einlesen und auch schreiben. Auch mit Excel-Dateien gibt es keine Probleme.


2. Calc

Wer schon eine der anderen OpenOffice Komponenten kennengelernt hat, der wird sich auch in Calc schnell zurecht finden.

2.1 Die Arbeitsoberfläche

Beim Start hat die Oberfläche von Calc folgenden Aufbau:

Ooo-calc1.jpg

Der Haupt-Teil des Fensters ist in Zeilen und Spalten unterteilt. Dabei sind die Spalten mit Buchstaben bezeichnet und die Zeilen mit Zahlen. Im Kreuzungspunkt von Zeilen und Spalten befinden sich die Zellen. Die Zellen werden mit dem Buchstaben der Spalte und der Nummer der Zeile gekennzeichnet. Die Zelle B3 befindet sich also in der zweiten Spalte (Buchstabe B) der dritten Zeile.

Jeweils eine der Zellen ist aktuell, sie besitzt einen deutlich dickeren Rand und im Namensfeld der Rechenleiste findet sich die zugehörige Positionsangabe. Zwischen den Zellen kann man sich mit Mausklicks oder den Cursortasten bewegen.

Die wichtigsten Funktionsleisten von Calc sind:

  • Menüleiste
  • Standardleiste
  • Formatleiste
  • Rechenleiste
  • Statusleiste

2.2 Die Standardleiste (Funktionsleiste)

2.3. Die Formatleiste

2.4. Die Rechenleiste

2.5. Die Statusleiste

3. Erste Schritte mit Calc

Eine Zelle kann sehr unterschiedliche Inhalte besitzen:

  • Texte
  • Zahlen
  • Rechenausdrücke

Normalerweise erkennt Calc automatisch den Typ einer Eingabe. Bewegen Sie die Markierung in das Feld A1 und geben Sie einen längeren Text ein, z.B. "Überschrift über meine erste Tabelle", zum Abschluss der Eingabe verlassen wir die Zelle oder drücken die Enter-Taste. Calc erkennt dies als Text und bricht ihn auch nicht am Ende der Zelle ab, sondern benutzt noch die leeren Nachbarzellen mit. Nur, wenn eine dieser Zellen einen eigenen Inhalt hätte, dann würde der Text aus Zelle A1 abgeschnitten werden müssen.

Nun bewegen wir uns in die Zelle B2 und geben dort z.B. 42 ein. Calc erkennt diese Eingabe als Zahl, wie man z.B. an der rechtsbündigen Ausrichtung erkennen kann. Texte werden nämlich immer linksbündig ausgerichtet und Zahlen bzw. Werte rechtsbündig.

Nun soll Calc einmal rechnen. Dazu bewegen wir uns in die Zelle B3 und geben 4+3 ein. Dummerweise betrachtet Calc diese Eingabe als Text, wie man an der linksbündigen Ausrichtung erkennen kann und daran, dass Calc nicht rechnet. Wenn die automatische Erkennung nicht zum gewünschten Ergebnis führt, dann kann man den Typ der Eingabe auch deutlich machen. Will man den Typ Text erzwingen, so startet man die Eingabe mit einem einfachen Anführungsstrich, '4 gibt also den Text 4 ein, mit linksbündiger Ausrichtung. Will man den Typ Zahl oder Rechenausdruck erzwingen, so beginnt man die Eingabe mit einem Gleichheitszeichen. Die Eingabe =4+3 führt also zu dem für Zelle B3 gewünschten Rechenausdruck, worauf in der Zelle dann das Ergebnis 7 zu sehen ist.

Nun soll Calc die beiden Zellen addieren. Dazu gehen wir in die Zelle B4 und machen dort folgende Eingabe:

=B2+B3

Wir starten also wieder mit dem Gleichheitszeichen und veranlassen Calc die Inhalte der Zellen B2 und B3 zu addieren. Es spielt übrigens keine Rolle, ob man das B groß oder klein schreibt, =b2+b3 wäre genauso zulässig.

Die Kalkulationstabelle sollte folgendermaßen aussehen:

Ooo-calc2.jpg

Geht man jetzt in die Zelle B2 und gibt dort statt der Zahl 42 eine andere Zahl ein, so aktualisiert Calc die Summe in Zelle B4 automatisch.

3.1 Eine Einkaufsliste

Für den nächsten Schritt brauchen wir wieder eine leere Tabelle. Eine Möglichkeit dafür ist es, alle bisherigen Eingaben zu löschen. Dazu geht man auf eine gefüllte Zelle und drückt auf die Taste Entf. Sollte ein kleines Menü erscheinen, so wählt man dort "Alles Löschen" und dann "OK".

Die Einkaufliste sollte etwa folgendermaßen aussehen:

Ooo-calc3.jpg

Bei dieser Kalkulation gibt es eine Reihe von kleinen Problemen. In der ersten Spalte werden viele Texte abgeschnitten, weil sie zu lang sind und die Nachbarspalte nicht leer ist. Die Spaltenbreite lässt sich ganz einfach ändern, indem man mit der Maus die Trennlinie zwischen A und B nach Rechts verschiebt. Damit lässt sich die Spaltenbreite recht genau an die Bedürfnisse anpassen.

Ein weiteres Problem ist die unterschiedliche Formatierung der Zahlen. Die Zahl der Nachkommastellen hängt von der Eingabe ab. Bei Preisen erwatet man aber in der Regel eine feste Zahl von zwei Nachkommastellen.

Über das Menü Format kann man den Menüpunkt Zellen... aufrufen. Hier finden sich recht viele Einstellmöglichkeiten.

Ooo-calc4.jpg

Im einfachsten Fall stellt man nur die Zahl der Nachkommastellen auf den Wert 2. Da wir hier aber mit Preisen arbeiten, macht es Sinn statt des Zahlen-Formates gleich das Währungsformat zu benutzen.

Ooo-calc5.jpg

Diese Änderung muss man nun nicht für jede Zelle einzeln vornehmen, sondern kann gleich mehrere Zellen auf einmal formatieren. Dazu markiert man entweder die entsprechenden Zellen, oder man markiert gleich die gesamte Spalte, indem man auf die Kopfzeile klickt. Wenn man jetzt wieder den Menüpunkt Zellen... aus dem Menü Format aufruft, dann wirken die Änderungen auf alle markierten Zellen.

Man kann das Währungsformat für eine Zelle übrigens auch ganz einfach erreichen, indem man bei der Eingabe das Währungssysmbol mit angibt. Die Eingabe 0,3€ führt also zum Eintragen der Zahl 0,3 und der Formatierung der Zelle als Währung.

Nun fehlt noch die Summe über alle Preise. Dazu geht man in die Zelle unterhalb der letzten Eingabe, im Beispiel B7 und klickt auf das Summensymbol in der Rechenleiste, es befindet sich zwischen dem f(x) und dem Gleichheitszeichen und erinnert an ein E. Calc gibt jetzt die Eingabe vor.

Ooo-calc6.jpg

Calc hat den Bereich markiert, der direkt über dem Feld steht und wenn man Enter drückt, dann wird die Eingabe übernommen. Dabei trägt Calc die Formel

=SUMME(B3:B6)

in die Zelle ein. Der Doppelpunkt in der Eingabe ist hier als Bis zu lesen. Es handelt sich also um die Summe von B3 bis B6 genau, was wir auch wollen. Gelegentlich gibt es einen schwer zu sehenden Fehler. Wenn statt des Doppelpunktes ein Semikolon steht, so ist dieses als Und zu lesen, B3 und B6 ergibt aber ein ganz anderes Ergebnis. Aufzählungen mit dem Semikolon dürfen übrigens auch mehrere Elemente besitzen, wir hätten auch schreiben können =SUMME(B3;B4;B5;B6), da ist aber die Darstellung mit dem Doppelpunkt deutlich praktischer.

Was jetzt noch fehlt, ist etwas Gestaltung. In der Überschriftszeile sollte der Text etwas größer sein. Zusätzlich soll über der Summe noch ein Doppelstrich angebracht werden. Dazu geht man in die Zelle mit der Summe, hier B7, und ruft wieder den Menüpunkt Zellen.. auf. Im Reiter Umrandung finden sich die entsprechenden Einstellmöglichkeiten.

Ooo-calc7.jpg

In dem großen Feld Benutzerdefiniert aktiviert man mit einem Klick die Linie oben und wählt dann Stil eine passende Linienart aus.

Die fertige Kalkulation sollte dann folgendermaßen aussehen:

Ooo-calc8.jpg


3.2. Was wäre wenn...

Eine sehr nützliche Funktion in Tabellenkalkulationen ist es, dass man relativ schnell verschiedene Möglichkeiten und Variationen durchrechnen kann. Im folgenden Beispiel gehen wir z.B. davon aus, dass ein Kind bei seiner Geburt ein Sparbuch mit einer bestimmten Geldsumme (1000,00€) geschenkt bekommt, und wollen ausrechnen, wieviel Geld nach 18 Jahren vorhanden ist, wenn regelmäßig 7,00% Zinsen pro Jahr erzielt wurden.

Die Tabelle soll fertig etwa folgendermaßen aussehen:

Ooo-calc.jpg

Dabei ergeben sich die Zahlen in den Spalten folgendermaßen:

  • 1. Spalte: Nummer der Jahres, fortlaufend
  • 2. Spalte: Kapital, ergibt sich aus dem Kapital des vorherigen Jahres plus der Zinsen des vorherigen Jahres
  • 3. Spalte: Zinssatz, konstant über die Laufzeit
  • 4. Spalte: Zinsbetrag, ergibt sich als Produkt aus dem Kapital und dem Zinssatz (s.u.)

Diese Tabelle wollen wir nun Schritt für Schritt aufbauen. Dabei wird es auch um die Möglichkeiten des geschickten Kopierens in der Tabellenkalkulation gehen.

Wir starten mit folgender Tabelle:

Ooo-calc9.jpg

In der Zeile 3 tauchen nur einfache Texte auf, die in 16 Punkt-Schrift und fett gestaltet wurden. In der Zelle A4 steht einfach nur die Zahl 1. Interessant wird es ab Zelle B4, wenn man hier gleich bei der Eingabe das Währungssymbol mit angibt, dann stellt Calc die Formatierung der Zelle gleich passend ein (s.o.). Entsprechend ist das in Zelle C4 mit dem Prozentsatz. Bei der Zinsrechnung muss man den Betrag mit dem Zinssatz multiplizieren und das Ergebnis durch 100 teilen oder gleich den Zinssatz durch 100 teilen. Sinnvoll wäre es also in der Zelle C4 nicht die Zahl 3 zu speichern, sondern gleich 0,03. Genau das mach Calc, wenn ich das Prozentzeichen mit eingebe, also in der Zelle C4 also 3% tippe. Zusätzlich stellt Calc auch die Formatierung der Zelle passend ein.

Nun geht es darum die einzelnen Spalten nach Unten zu verlängern, bis zum 18. Jahr. Im ersten Schritt gehen wir dazu in die Zelle A4. Rechts unten am Rand befindet sich ein kleines schwarzes Quadrat. Dieses kleine Quadrat kann man mit der Maus anfassen und mit gedrückter Maustaste nach Unten ziehen.

Ooo-calc12.jpg

Lässt man jetzt die Maustaste los, so kopiert Calc die Zelle, wobei es den Inhalt jeweils um 1 erhöht, eine recht clevere Kopierfunktion.

Die Kopierfunktion kann aber noch mehr, hätte man in dem Ausgangsfeld einen Monat angegeben, wie z.B. April, so stünden in den kopierten Zellen jeweils die Folgemonate. Entsprechend funktioniert das auch mit den Wochentagen. Bei den Zahlen gibt es manchmal den Wunsch, dass nicht immer um 1 erhöht wird, sondern jeweils um z.B. 5. Dann schreibt man in das Ausgangsfeld die erste Zahl und in das Feld darunter die um 5 höhere Zahl, markiert beide Felder und kopiert wieder nach Unten, Calc erhöht dann jeweils um 5.

Ooo-calc13.jpg

Die eben gemachten Überlegungen können wir gleich auf die dritte Spalte anwenden. Hier soll ja immer der gleiche Zinssatz auftauchen. Dazu brauchen wir zwei Zellen übereinander mit dem gleichen Inhalt, wenn ich die gemeinsam nach Unten kopiere, bleibt der Inhalt gleich. Wir gehen also in Zelle C4 und wählen Kopieren aus dem Menü Bearbeiten. Dann wechseln wir in Zelle C5 und wählen Einfügen aus dem gleichen Menü. Beim klassischen Kopieren verändert Calc die Inhalte nicht. Nun markiere ich C4 und C5 gemeinsam und ziehe nach Unten.

Nun fehlt noch Zelle D4 mit dem Zinsbetrag. Dieser ergibt sich als Produkt aus dem Kapital und dem Zinssatz, wir geben also die Formel =B4*C4 in das Feld ein. Diese Formel kopieren wir dann nach Unten, wobei uns auch hier wieder die Kopierfunktion von Calc unterstützt. Die Formel wird nämlich beim Kopieren angepasst aus =B4*C4 wird in der nächsten Zeile =B5*C5, dann =B6*C6, ... Calc fasst die Verweise auf die Zellen nämlich als relative Verweise auf und kann sie daher anpassen.

In der zweiten Spalte können wir leider noch nicht kopieren, das Kapital muss sich ja um den Zinsbetrag erhöhen (Kapital vom Vorjahr plus Zinsbetrag vom Vorjahr). Hier müssen wir erst die passende Formel eingeben, in diesem Fall also =B4+D4 . Wenn die Formel richtig eingegeben ist, dann können wir sie nach Unten kopieren und Calc passt die Formel entsprechend an.

Wenn wir jetzt noch die Zelle D4 nach Unten kopieren, dann ist die Kalkulation fertig. Nun können wir relativ bequem den Ausgangsbetrag ändern oder auch den Zinssatz. Wer den Verlauf über mehr als 18 Jahre berechnen möchte, der muss die Spalten nur weiter nach Unten kopieren.


3.3 Eine verbesserte Zinsbererechnung

Das eben durchgespielte Beispiel hat ein paar Nachteile. Besonder lästig ist es, dass Veränderungen am Zinssatz immer umfangreiche Kopieraktionen nach sich ziehen. Man kann leider auch nicht einfach eine ganze Zeile nach Unten ziehen, dann würde auch der Zinssatz erhöht.

Sinnvoll kann hier eine Klakulation sein, bei der die beiden Parameter Ausgangskapital und Zinssatz in einen extra Bereich herausgezogen werden und jeweils nur einmal auftauchen.

Ooo-calc14.jpg

Auch diese Kalkulation bauen wir schrittweise auf. Ausgangspunkt ist wieder eine Tabelle nur mit konstanten Werten.

Ooo-calc15.jpg

In der Vorlage ist ein Rahmen um den Kopfbereich zu sehen. Um den zu erzeugen, markiert man den gesamten Bereich von A1 bis C3 (einschließlich der leeren Zellen am Rand) und wählt dann Zellen... aus dem Menü Format. Benötigt wird aus dem Menü der Reiter Umrandung, hier nimmt man anzwei Stellen Änderungen vor.

Ooo-calc16.jpg

Man wählt z.B. bei Linienanordnung den äußeren Rahmen und bei Linienstil eine etwas dickere Linie.

Nun geht es an die eigentliche Tabelle. Das Feld A6 kann einfach nach unten kopiert werden. In das Feld B6 muss irgendwie der Ausgangsbetrag hinein, aber nicht als Zahl, sondern als Formel die auf den Kopfbereich verweist. Nur dort soll ja der Ausgangsbetrag stehen, also kommt hier die Formel =B2 hinein. In das Feld B7 kommt dann wieder die Summe aus dem Kapital des Vorjahres und dem Zinsbetrag des Vorjahres, also =B6+C6 hinein. Diese Formel kann man jetzt problemlos kopieren, es müsste dann immer 1000€ als summe auftauchen, da wir ja noch den Zinsbetrag nicht berechnet haben.

Der Inhalt des Feldes C6 ist nun relativ einfach zu beschreiben. Ich muss das Kapital des Jahres (Feld B6) multiplizieren mit dem Zinssatz, den ich jetzt im Feld B1 finde. Es ergibt sich die Formel = B6*B1 .

Auf den ersten Blick klappt die Berechnung des Zinsbetrages, wenn ich die Formel jetzt aber kopiere, dann ergibt sich ein Fehler. Im Feld C7 taucht eine zu große Zahl auf, im Feld C8 dann wieder 0. Das hängt damit zusammen, dass Calc die Formel beim Kopieren natürlich wieder angepasst hat. Im Feld C7 steht als Formel =B7*B2 und in B2 steht das Kapital und nicht der Zinssatz, was den hohen Wert erklärt.

Man müsste Calc sagen können, dass es den Verweis auf die Zelle B1 beim Kopieren nicht verändern darf, der Bezug auf diese Zelle also absolut bleiben muss. Das ist zum Glück relativ einfach zu machen. Gibt man in C6 die Formel =B6*$B$1 ein, so verändert Calc den Verweis auf die Zelle B1 beim Kopieren nicht mehr, die Dollarzeichen kennzeichnen einen absoluten Verweis.

Ooo-calc17.jpg


4. Diagramme mit Calc

Mit der Tabellenkalkulation kann man recht einfach Diagramme zu Tabelleninhalten erzeugen. Auch diese Diagramme passen sich bei Veränderungen in der Kalkulation dynamisch an.

Ooo-calc18.jpg


4.1 Diagramm zur Zinsberechnung

Zum Erzeugen eines derartigen Diagrammes markiert man sich zuerst den Datenbereich mit den Überschriften, im Beispiel also den Bereich von A5 bis C23. Dann klick man auf Diagramm... im Menü Einfügen. Es folgen einige Dialoge, die man sinnvoll beantworten sollte.

Ooo-calc19.jpg

Im ersten Fenster sollte man darauf achten, dass beide Häkchen zum Bereich Beschriftung gesetzt sind. Bei uns sind ja sowohl die Kopfzeile, als auch die Jahreszahlen als Diagrammbeschriftung zu betrachten.

Nach einem Klick auf Weiter geht es darum den Diagrammtyp auszuwählen.

Ooo-calc20.jpg

Der Typ Linien ist für unsere Zwecke gut passend. Nach einem erneuten Klick auf Weiter kann man nun Varianten auswählen.

Ooo-calc21.jpg

Hier ist keine Änderung notwendig, Normal ist die passende Variante. Also wieder auf Weiter klicken. Im nächsten Fenster ist etwas mehr auszufüllen.

Ooo-calc22.jpg

Hier geht es um die Beschriftung des Diagrammes, insofern sind hier einige Eintragungen notwendig. Zum Abschluss klickt man auf Fertigstellen, worauf Calc das Diagramm in die Kalkulation einfügt. Das Digramm kann jederzeit verschoben und in der Größe verändert werden.

Was die Positionierung des Diagrammes betrifft, unterscheidet sich der beschriebene Weg über das Menü vom Weg über das Icon Diagramm in der Standardleiste. Wenn man die Diagramm-Funktion über das Icon aufruft, dann muss man im ersten Schritt den Bereich auf der Seite aufziehen, in dem Calc das Diagramm unterbringen soll, man kann das an einem veränderten Cursor gut erkennen. Die weiteren Dialoge unterscheiden sich aber nicht.

4.2 Bearbeiten von Diagrammen

Diagramme kann man auch nachträglich jederzeit verändern und anpassen. Dabei muss man aber darauf achten, dass ein Diagramm mehrere verschiedene Aktivierungszustände besitzt. Klickt man einmal mit der Maus auf das Diagramm, so tauchen wie bei allen Objekten die grünen Rechtecke am Rand auf.

Ooo-calc23.jpg

Klick man doppelt auf das Diagramm, so wird es von einem grauen Kasten umgeben und es stehen ganz andere Bearbeitungsfunktion zur Verfügung.

Ooo-calc24.jpg