OpenOffice-Draw

Aus Debacher-Wiki
Wechseln zu: Navigation, Suche


1. Zeichnen statt Malen

Im Computerbereich sind zwei Arten von Anwendungen bzw. Dateiformaten gebräuchlich.

  • Pixel-linie.jpg
    Einerseits Malprogramme wie MS-Paint, bei denen alle Abbildungen aus einzelnen Punkten zusammengesetzt sind. Man kann in der Bedienoberfläche dieser Programme zwar Linien, Rechtecke oder Kreise zum Zeichnen auswählen, sowie die Objekte aber dargestellt sind kann die Anwendung diese nicht mehr als solche Verschieben, da nur Menge von Punkten gezeichnet wird. Der Bildschirmpunkt ist das einzige Objekt, welches diese Anwendungen wirklich kennen. Nachträglich ist es auch nicht mehr möglich die Farbe oder die Breite einer Linie zu verändern.
    Beim Vergrößern eines derartig gemalten Bildes werden schräge oder runde Linien zu recht stufigen Gebilden.
  • Deutlich flexibler sind die Zeichenprogramme, wie z.B. OpenOffice.org Draw. Derartige Programme besitzen intern eine Beschreibung für Objekte wie Linien, Kreise und Rechtecke. Du kannst daher die Objekte jederzeit erneut auswählen und jede ihrer Eigenschaften verändern.
    Auch beim Vergrößern eines Ausschnittes bleiben alle Linien glatt und gleichmäßig, da die Darstellung des Objektes der neuen Auflösung angepasst wird. Da auch die Druckqualität entsprechend hoch ist, arbeiten alle Konstruktionsprogramme objektorientiert.


1.1 Werkzeuge

Das Programm Draw ist also ein vektororientiertes Zeichenprogramm und dazu sehr gut in das Gesamtpaket OpenOffice.org integriert.


1.2 Für Umsteiger

Wer bisher nur mit Malprogrammen gearbeitet hat, der wird sich am Anfang etwas umstellen müssen. Am auffälligsten wird in der Anfangszeit das Fehlen eines Pinsel-Werkzeugs sein. Es wird sich aber schnell zeigen, dass ein Zeichenprogramm über eine Vielzahl von zusätzlichen Möglichkeiten verfügt.

Wer schon vorher mit Zeichenprogrammen gearbeitet hat, der wird mit Draw sehr schnell zurecht kommen.


2. Draw

Die Zeichenkomponente von OpenOffice.org heiß ganz schlicht Draw. Sie ist in der aktuellen Version von OpenOffice/StarOffice deutlich überarbeitet worden.

2.1. Die Arbeitsoberfläche

Beim Start hat die Arbeitsoberfläche von Draw folgenden Aufbau:

Draw-leisten.jpg

Man sieht hier eine Reihe von Leisten und ein zweigeteiltes Fenster. Im rechten Teil findet sich die eigentlich Zeichenfläche, mit den Proportionen des eingestellten Papierformates. Im linken Teil findet sich der Seitenbereich mit einer Vorschau, man kann also mehrere Zeichnungen gleichzeitig im Zugriff haben.

In der Regel ist es sinnvoll den Vorschau-Bereich zu entfernen, indem man auf das kleine "x" hinter dem Wort Seite klickt. Ein anderer Weg zum Entfernen des Seitenbereiches führt über das Menü Ansicht und den Menüpunkt Seitenbereich. Ist hier ein Häkchen gesetzt, dann ist der Bereich sichtbar, wenn kein Häkchen vorhanden ist, dann ist der Bereich unsichtbar. Auf diesem Weg kann man den Bereich natürlich auch wieder sichtbar machen.

Die wichtigsten Funktions-Leisten von Draw sind

  • Funktionsleiste
  • Objektleiste
  • Leiste Zeichnen

Dazu kommen ggf. auch noch die Bildlaufleisten und natürlich die Menüleiste über die alle grafischen Anwendungen verfügen. Über die Menüleiste sind alle Funktionen erreichbar, die folgenden Beschreibungen benutzen aber soweit möglich den Weg über die Symbolleisten. Welche der Symbol-Leisten aktuell sichtbar sind hängt vom Arbeits-Kontext ab. Über den Menüpunkt Ansicht -> Symbolleisten besteht zusätzlich die Möglichkeit die Leisten und ihre Darstellung zu Konfigurieren.

Draw-symboll.jpg

Auf das Thema Ebenen und damit die Ebenen-Auswahl kommen wir später zurück. Im Prinzip ist es so, dass jede Ebene eine durchsichtige Folie darstellt, auf der ich Malen kann. Mehrere dieser Folien, also die Ebenen, können zur Darstellung überlagert werden. Am Anfang ist es nur wichtig darauf zu achten, dass der Reiter Layout ausgewählt ist.

2.2. Die Funktionsleiste (Standard)

Direkt unterhalb der Menüleiste finden Sie die Funktionsleiste bzw. Standard-Leiste. Hier sind die Funktionen untergebracht, die sich auf das Dokument als Ganzes beziehen. Draw-leiste-funktion.jpg

Dazu gehören Neu, Öffnen, Speichern und Drucken. Und natürlich auch Ausschneiden, Kopieren und Einfügen. Diese Leiste ist in allen Komponenten von OpenOffice.org vorhanden und hat auch immer fast den gleichen Aufbau.

Im rechten Teil der Leiste, nach den den Pfeilen für Rückgängig bzw. Wiederherstellen finden sich Funktionen, die für die Komponente spezifisch sind. Wir werden einige der Funktionen noch kennen lernen.

Draw-zoom.jpg
Eine Besonderheit taucht hier bei dem Eintrag Zoom, fast am Ende der Leiste, zum ersten Mal auf. Rechts neben dem Icon ist ein kleines schwarzes Dreieck zu sehen. Wenn man auf dieses Dreieck klickt, oder längere Zeit auf das Icon, dann öffnet sich ein weiteres Menü. Geht man mit der Maus über die Kopfzeile dieses Menüs, so kann man diese anklicken und das ganze Menü aus der Funktionsleiste herausziehen. Es entsteht dann eine schwebende Leiste, die sich an beliebiger Stelle des Fensters unterbringen lässt.

Diese Möglichkeit, Leisten herausziehen zu können, findet sich oft dann, wenn ein schwarzes Dreieck neben dem Icon zu sehen ist. Sehr oft findet sich diese Funktion in der Zeichenen-Leiste.

Leider ist es so, dass sich manchmal zwar ein schwarzes Dreieck findet, aber nicht die Abreissfunktion für eine Unterleiste. Bei Neu, Rückgängig und Wiederherstellen sind zwar Dreiecke vorhanden, beim Anklicken öffnet sich aber nur eine Liste die man nicht abreißen kann.

2.3. Die Objektleisten

Die zweite Leiste von Oben ist die Objektleiste, die es in ähnlicher Form für jede Programmkomponente gibt. Da es innerhalb von Draw verschiedene Arten von Objekten gibt existieren auch verschiedene Objektleisten.

Wenn kein Objekt oder ein Grafik-Objekt markiert ist, dann ist die Leiste Linie und Füllung zu sehen.

Draw-leiste-gobjekt.jpg

Ist ein Textobjekt markiert, so wird die Leiste Linie und Füllung durch die Leiste Text Format ersetzt.

Draw-leiste-tobjekt.jpg


2.4 Leiste Zeichnen

Über diese Leiste besteht die Möglichkeit Elemente wie Rechtecke, Linien, Smileys und Pfeile in die Textdokumente zu integrieren.

Draw-leiste-zeichnen.jpg

Eine sehr interessante Funktion ist in der Zeichnen-Leiste normalerweise ausgeblendet, Klickt man auf das kleine schwarze Dreieck am rechten Ende einer Leiste, so öffnet sich ein kleines Menü. Über dessen ersten Menüpunkt Sichtbare Schaltflächen lässt sich einstellen, welche Schaltflächen auf der Leiste vorhanden sein sollen.

Draw-leiste-zeichnen-plus.jpg

Hier sollte man die Schaltfläche 3D-Objekte zusätzlich aktivieren.

2.5 Draw und seine Leisten

Draw-leisten2.jpg
Bisher war schon von einer Vielzahl von Leisten die Rede. Bei einer bereits benutzten OpenOffice.org-Version kann die Anordnung der Leisten von der Beschreibung abweichen. Generell kann man bei OpenOffice Leisten fast immer aus ihrer Verankerung lösen, aber auch an anderen Stellen wieder andocken. Damit lässt sich die Arbeitsumgebung an die eigenen Bedürfnisse anpassen.

Nehmen wir als Beispiel einmal die bereits beschriebene Symbolleiste Zeichnen, die sich normalerweise direkt oberhalb der Statuszeile befindet. Ganz vorne in der Leiste kann man eine Spalte von Punkten erkennen. Wenn man hier mit der Maus drauf klickt, dann kann man die Leiste mit weiter gedrückter Taste aus ihrer Position herausziehen. Man kann die Leiste dann frei verschieben und bei Bedarf wieder an einer der Bildschirm-Kanten andocken lassen. Die nebenstehende Abbildung zeigt eine Zeichnen-Leiste, die am linken Rand des Fensters angedockt wurde. Falls der eigene Bildschirm eine genügend große Auflösung besitzt kann man die Zeichnen-Leiste auch neben der Funktions-Leiste positionieren.

Die Abbildung zeigt übrigens eine Version der Zeichnen-Leiste mit aktivierter Schaltfläche 3D-Objekte, es ist dort das dritte Icon von Unten, mit dem räumlich dargestellten Würfel.


3. Eine einfache Zeichnung

Im folgenden soll eine erste Zeichnung mit Draw erstellt werden, ein kleiner Trecker.

Draw-traktor.jpg

Dieses Bild wollen wir schrittweise aufbauen, von Unten nach Oben.

3.1. Die Grundlinie

Im ersten Schritt soll die Grundlinie entstehen, die die Straße symbolisiert. Die Linie sollte etwa in der Mitte der Seite über die gesamte Zeichenfläche gehen.

Man aktiviert in der Zeichenen-Leiste das zweite Icon Linie und klickt dann in die Zeichenfläche, das legt den Anfangspunkt fest. Dann zieht man mit immer noch gedrückter Maustaste die Maus an den Endpunkt der Linie. Sowie man die Maustaste loslässt ist die Linie festgelegt. Sie ist noch markiert, wie man an den grünen Markierungen an den Linienenden erkennt. Es ist nicht immer einfach die Linie auch wirklich gerade zu bekommen. Dafür ist es hilfreich während des Ziehens der Linie eine der Shift-Tasten auf der Tastatur zu drücken (das sind die mit denen man an die großen Buchstaben herankommt). Zieht man nämlich die Maus bei gedrückter Shift-Taste, so zeichnet Draw eine Linie nur waagrecht, senkrecht oder mit einem Winkel von 45°.

Die Linie soll deutlich dicker und auch schwarz werden. Dazu muss die Linie markiert sein, also an den Enden die grünen Markierungen auftauchen. Sollte sie nicht aktiv sein, so klickt man sie einmal an. Nun kann man aus der Objektleiste heraus die dicke und die Farbe der Linie verändern.

3.2. Die Räder

Als nächstes kommen die beiden Räder. In der Zeichenleiste gibt es kein Symbol Kreis, wohl aber Ellipse. Also Ellipse aktivieren, in die Zeichnung klicken und mit der gedrückten Maustaste die Ellipse aufziehen. Mit etwas Geschick kann man mit der Ellipsen-Funktion auch Kreise zeichnen, etwas einfache geht es aber, wenn man die Shift-Taste auf der Tastatur drückt, dann achtet Draw selber darauf, dass die Ellipse ein Kreis wird.

Die Räder müssen dann noch auf die Füllfarbe Schwarz eingestellt und an die richtige Position verschoben werden. Im Zweifelsfall schiebt man die Kreise besser etwas zu weit in die Straße hinein. Wer seine Objekte sehr genau positionieren möchte, der kann sie mit der rechten Maustaste anklicken.

Draw-kontextmenue.jpg

Es erscheint ein Kontext-Menü, aus dem heraus man dann über den Punkt Position und Größe die Eigenschaften sehr exakt einstellen kann.

Draw-groesse.jpg

3.3. Das Fahrzeug

Der Hauptteil des Fahrzeuges besteht aus drei Rechtecken. Zwei grün gefüllten Rechtecken und einem weiß gefüllten Rechteck. Zuerst kommt das größere Rechteck für das eigentliche Fahrzeug. In der Zeichenleiste findet sich das Symbol Rechteck, welches sich hierfür ganz einfach benutzen lässt. Wenn man jetzt das Rechteck zeichnet, dann verdeckt es leider die Räder. Das ist ganz normal, später gezeichnete Objekte liegen immer über den früher gezeichneten Objekten. Ändern lässt sich das über die Funktion Anordnung ziemlich am Ende der Zeichnen-Leiste.

Draw-anordnung.jpg

Wählt man hier Ganz nach Hinten, so stimmt die Reihenfolge. Nun müssen nur noch die Farbe sowie Größe und Position entsprechend angepasst werden.

Beim zweiten grünen Rechteck, dem Fahrerhaus kommt es etwas auf die exakte Positionierung der rechten Kante an. Mit etwas Fingerspitzengefühl oder über das Menü Position und Größe kommt man aber zur richtigen Position.


3.4. Das Dach

Für das Dach gibt es in Draw leider keine Zeichenfunktion Dreieck. Das ist aber nicht weiter schlimm. In der Zeichnen-Leiste gibt es das Symbol Kurve. Klickt man hier auf das kleine Dreieck rechts neben dem Icon, so öffnet sich eine weitere Symbolleiste.

Draw-polygon1.jpg

Über diese Symbolleiste stehen mehrere Arten von Linienzügen bzw. Polygonen zu Auswahl. Für die Konstruktion des Daches ist Polygon, gefüllt die beste Wahl. Zum Zeichen eines Polygons startet man mit dem ersten Punkt, zieht dann die Maus mit gedrückter Maustaste zum zweiten Punkt, lässt die Maustaste los, geht zum nächsten Punkt und klickt dort einmal, geht dann zum nächsten Punkt klickt dort einmal, .... Hat man den letzten Punkt erreicht, dann führt man einen Doppelklick aus, worauf Draw den letzten Punkt mit dem ersten verbindet und das Zeichen beendet. Will man einige Linien waagrecht oder senkrecht haben, so kann man wieder die Shift-Taste mit einsetzen.

Für das Dach geht man also folgendermaßen vor. Polygon, gefüllt aktivieren, mit der Maus den vorderen Eckpunkt des Daches anklicken und dann mit gedrückter Maustaste und gedrückter Shift-Taste die Maus zum hinteren Eckpunkt des Daches ziehen. Dann die Tasten loslassen und die Maus etwas hoch und nach Hinten ziehen und mit einem Doppelklick das Dach fertigstellen.

Sollte die Positionierung eines der Eckpunkte nicht ganz gelungen sein, so kann man die Punkte eines Polygons jederzeit einzeln bearbeiten. Dazu aktiviert man im Kontextmenü des Objektes den Menüpunkt Punkte bearbeiten.

Draw-punkt.jpg

Das Dach wird jetzt nicht mehr durch acht Markierungspunkte rechteckig eingefasst, sondern es sind nur noch die drei Eckpunkte markiert und können einzeln verschoben werden.


3.5. Erweiterungsmöglichkeiten

Die Zeichnung lässt sich natürlich beliebig erweitern. Denkbar wäre z.B. ein Auspufg mit einer kleinen Abgaswolke.

Draw-traktor1.jpg

Für die Abgaswolke eignet sich übrigens die Funktion Freihandlinie, gefüllt aus dem Punkt Kurve der Leiste Zeichnen.


3.6. Drehen von Objekten

Mit Draw kann man Objekte auch nachträglich noch ganz einfach drehen. Dazu markiert man entweder ein einzelnes Objekt, oder gleich die gesamte Zeichnung, über das Menü Bearbeiten und den Menüpunkt Alles auswählen. Sowie etwas markiert ist kann man in der Zeichnen-Leiste im Untermenü Effekte den Menüpunkt Drehen auswählen. Die grünen Griffpunkte werden rund und rot, am anzudeuten, dass die Funktion Drehen aktiviert ist.

Draw-drehen.jpg

Nun kann man einen der roten Eckpunkte mit der Maus fassen und durch Ziehen an diesem Punkt die gesamte Zeichnung drehen. Der Mittelpunkt der Drehung wird ebenfalls angezeigt und lässt sich bei Bedarf ebenfalls verschieben. Die Shift-Taste hat hier auch wieder die Funktion nur bestimmte Drehwinkel zu erlauben. Die mittleren roten Punkte haben übrigens hier noch keine Funktion, die werden erst für 3D-Objekte benötigt.

Über den Reiter Drehen im Menü Position und Größe, welches man mit einem Klick mit der rechten Maustaste auf ein Objekt erhält, lässt sich die Drehung sehr exakt kontrollieren.

Draw-drehen1.jpg

Sind mehrere Objekte gleichzeitig markiert, wie hier die gesamte Zeichnung, dann lässt sich dieses Menü nicht aufrufen. Dazu müsste man erst die Einzelobjekte zu einem einzigen Objekt gruppieren. Zum Gruppieren markiert man alle Objekte die zusammengefasst werden sollen und wählt dann aus dem Kontextmenü den Punkt Gruppieren.


4. Räumliche Objekte

Eine Besonderheit von Draw ist die Möglichkeit mit 3D-Objekten umgehen zu können. Wobei man aber deutlich machen muss, dass Draw kein wirkliches 3D_programm ist. Das wird spätestens dann deutlich, wenn man erreichen will, dass sich Objekte durchdringen. Das kann Draw nicht, die Objekte lassen sich nur überlagern.


4.1. Mitgelieferte 3D Objekte

Draw-3dobjekte.jpg
Über die Zeichnen-Leiste kommt man an ein Untermenü 3D Objekte heran, zumindest wenn man diesen Punkt aktiviert hat, wie im Abschnitt 2.4. beschrieben.

Die Objekte lassen sich genauso einfach in eine Zeichnung einfügen, wie normale Rechtecke oder Kreise.

Draw-3dobjekte2.jpg

Beim Drehen eines derartigen 3D-Objektes haben übrigens auch die mittleren roten Punkte eine Funktion, sie kippen das Objekt gegenüber der Ebene. Damit lassen sich recht interessante Zeichnungen gestalten.


4.2. Umwandeln in ein 3D-Objekt

Wenn keine Gruppierung vorhanden ist, im Zweifelsfall alles markieren und Gruppierung auflösen aktivieren, dann kann man normale Objekte in 3D-Objekte umwandeln. Dazu markieren wir wieder alles Teile des Treckers über das Menü Bearbeiten und den Menüpunkt Alles auswählen. Es kann sich dabei ruhig um die gedrehte Version des Treckers handeln.

Nun wählen wir im Kontextmenü Umwandeln und im Untermenü In 3D aus.

Draw-umwandeln.jpg

Der Trecker verändert sein Aussehen erheblich und bekommt einen räumlichen Effekt.

Draw-umwandeln1.jpg


4.3. Rotationskörper

Eine weitere Möglichkeit räumliche Objekte selbst zu konstuieren stellen Rotationskörper dar. Hier nimmt man einen Linienzug und lässt Draw diesen Linienzug rotieren.

Draw-3dobjekte3.jpg

In diesem Beispiel ist der Linienzug links einfach mit der Funktion Freihandlinie aus dem Menü Kurve gezeichnet. Aktiviert man jetzt im Kontextmenü der Kurve das Untermenü Umwandeln und dort den Punkt In 3D-Rotationskörper, dann entsteht ein kelchartiges Objekt.


4.4 3D-Effekte

Die 3D-Objekte von Draw verfügen alle im Kontextmenü über einen Menüpunkt 3D-Effekte. Über dieses Menü kann man alle möglichen Eigenschaften des Objektes verändern. Dazu gehören vor allem die Farben und die Lichtquellen. Gerade das Zusammenspiel zwischen Farbe und Lichtquelle beeinflusst sehr stark den räumlichen Eindruck.

Draw-3dobjekte4.jpg

Über den Reiter Beleuchtung kann man mehrere Lichtquellen aktivieren. Diese Lichtquellen lassen sich positionieren, indem man die kleine weiße Kugel (die Lichtquelle) auf den gelben Bahnen verschiebt.

Die große rote Kugel dient hier nur als Vorschau, Änderungen wirken erst dann auf das eigentliche Objekt, wenn man auf das grüne Häkchen oben rechts klickt.


5. Exakte Zeichnungen mit Maßlinien

Gelegentlich möchte man sehr exakte Zeichnungen anfertigen, z.B. Grundrisse von Zimmern oder Wohnungen. Bei diesen Zeichnungen müssen die einzelnen Objekte sehr genau positioniert und zusätzliche Längenangaben untergebracht werden.

Draw-masslinie4.png


5.1. Raster

In der Standardeinstellung weist die Zeichenfläche von Draw ein Punktmuster auf, das sog. Raster. Dieses Raster dient zur Orientierung und exakten Positionierung von Zeichenelementen. Bei der Positionierung der Zeichenelemente kann man sich von Draw helfen lassen, indem man die Funktion Am Raster fangen aktiviert. Dann lässt Draw bei neuen Objekten, oder beim bearbeiten von Objekten, nur noch zu, dass diese exakt an Rasterpunkten liegen.

Zum Aktivieren dieser Funktion klickt man mit der rechten Maustaste in einen freien Bereich der Seite, wähl aus dem Kontextmenü den Menüpunkt Raster und aktiviert dort dann Am Raster fangen.

Draw-raster1.png

Bereits positionierte Objekte werden durch diese Einstellung nicht betroffen, erst wenn diese bewegt werden richten sie sich am Raster aus.

Das Raster selber, also z.B. die Abstände der Rasterpunkte, lässt sich über den Menüpunkt Optionen im Menü Extras konfigurieren.

Draw-raster2.png


5.2. Fangpunkte und Fanglinien

Für manche Anwendungen ist ein Raster zu wenig flexibel, man müsste die Rasterpunkte eventuell viel zu eng setzen. Für solche Fälle gibt es die Möglichkeit Fangpunkte bzw. Fanglinien zu setzen. Ein Fangpunkt ist nichts weiter, als ein einzelner Rasterpunkt er lässt sich sehr individuell positionieren. Analog zum Fangpunkt arbeitet die Fanglinie.

Fankgpunkte bzw. Fanglinien muss man erst in die Zeichenfläche einfügen. Das sollte aber nicht in der normalen Zeichenebene Layout erfolgen, sondern in der dafür gedachten Ebene Controls.

Draw-controls.png

Also erst einmal durch Anklicken des Reiters Controls in die entsprechende Ebene wechseln. Dort kann man jetzt die Fanglinien und Fangpunkte einfügen, indem man aus dem Kontextmenü der Seite (mit der rechten Maustaste in einen freien Bereich klicken) den Menüpunkt Fangpunkt/-Linie einfügen wählt. Es erschein ein kleines Menü.

Draw-fang1.png

Hier kann man exakt die Koordinaten des Punktes angeben. Zu den Fanglinien ist zu sagen, dass diese immer über die gesamte Seite gehen, also durch die Angabe eines einer einzigen Koordinate eindeutig definiert sind, da es nur waagrechte und senkrechte Fanglinien gibt.

In der Grundeinstellung sind die Fangpunkte und Fanglinien nicht sichtbar. Da kann man über das Kontextmenü der Seite leicht ändern.

Draw-fang2.png

Hier muss man die Sichtbarkeit der Fanglinien einstellen und auch an der Fanglinie fangen aktivieren, damit die Fanglinie auch einen Effekt hat.


5.3 Ebenen

Draw erlaubt das Arbeiten mit mehreren Ebenen. Die Ebenen muss man sich vorstellen wie durchsichtige Folien, die zum Betrachten übereinander gelegt werden. Liegen alle Folien übereinander sehe ich die komplette Zeichnung. Will ich einzelne Elemente, z.B. die Fanglinien, nicht sehen, so nehme ich die Folie aus dem Folienstapel heraus bzw. mache sie unsichtbar.

Draw richtet generell für Zeichnungen drei Ebenen ein, die sich auch nicht entfernen lassen. Das sind die Ebenen:

  • Layout
  • Controls
  • Maßlinien

die eigentlich Zeichnung kommt in die Ebene Layout. Fanglinien und Fangpunkte in die Ebene Controls und Maßangaben in die Ebene Maßlinien. Weitere Ebenen lassen sich jederzeit einrichten.

Draw-ebenen1.png

Dazu klickt man im Kontextmenü der Registerkarte Ebene auf Ebene einfügen... Die selbst eingefügten Ebenen lassen sich auch wieder löschen, die drei Standardebenen nicht.

Für jede Ebene kann man einstellen, ob sie sichtbar ist, oder nicht. Dazu geht man entweder wieder über das Kontextmenü und dann Ebene ändern, oder man führt einen Doppelklick auf den Reiter der Ebene aus.

Draw-ebenen2.png

Bei der Sichtbarkeit einer Ebene unterscheidet Draw zwischen Bildschirm und Drucker. Ich kann also Hilfslinien (Controls) auf dem Bildschirm sichtbar machen, in der Druckausgabe aber weglassen. Wenn man den Punkt Gesperrt aktiviert, dann sind (versehentliche) Änderungen an der Ebene nicht möglich.

Hinweis: Die Sichtbarkeit der Maßlinien lässt sich nur generell über das Kontextmenü der Seite und dort das Untermemü Fanglinien regeln. Die Sichtbarkeit der Ebene spielt für die Sichtbarkeit der Fanglinien keine Rolle.


5.4 Maßlinien

Die Länge einer Strecke kann man von Draw automatisch in die Zeichnung integrieren lassen. Dazu benutzt man die Maßlinien, die man üblicherweise in der gleichnamigen Ebene unterbringt.

In der Zeichnenleiste findet sich das Auswahlmenü Linien und Pfeile, klappt man dieses Menü auf, so gibt es dort den Eintrag Maßlinie.

Draw-masslinie1.png

Verbindet man jetzt mit dieser Linie zwei Hilfslinien, so werden die Abmessungen automatisch ergänzt.

Draw-masslinie2.png

Sollte die vorgegeben Einheit und Skalierung nicht passend sein, so kann man die entsprechenden Einstellungen im Menüpunkt Optionen des Menüs Extras verändern.

Draw-masslinie3.png

Hier sind vor allem die Maßeinheit und der Zeichnungsmaßstab entscheidend.

Ein Grundriss mit Fanglinien und Bemaßung würde dann auf dem Bildschirm folgendermaßen aussehen.

Draw-masslinie5.png


6. Grafikformate

Draw speichert seine Grafiken in dem eigenen Vektorformat mit der Endung .ODG. Viele ältere Programm können mit diesem Format nicht umgehen. Da trifft es sich gut, dass Draw in sehr vielen verschiedenen anderen Formaten speichern und auch sehr viele andere Formate öffnen kann.

Zum Speichern der Grafik in einem Format wie JPG oder PNG geht man im Menü Datei auf den Menüpunkt Exportieren... Draw bietet dann eine Vielzahl von Formaten zur Auswahl an.

Draw-export.jpg

Bei der Mehrzahl der Formate handelt es sich um Pixelformate, der Export ist also mit einem Informationsverlust verbunden. Man sollte die Zeichnung daher auch immer im Draw-Format speichern.

Eine besondere Bedeutung kommt den Export-Formaten Flash und PDF zu. In diesen Formaten lässt sich eine Zeichnung auch relativ einfach ins Web stellen. Das PDF-Format ist generell für die Weitergabe von Dokumenten ideal, die auf fremden Rechnern ausgedruckt werden sollen. Eine PDF-Datei sieht überall gleich aus, zumindest soweit das überhaupt möglich ist.

Das Einlesen von Fremdformaten ist ebenfalls ganz einfach, beim Öffnen einer Datei sind alle gebräuchlichen Formate möglich. Wobei natürlich eine Grafik im PNG oder JPG Format nicht so gut zu bearbeiten ist, wei eine Datei in einem Vektorformat.