OpenOffice-Writer

Aus Debacher-Wiki
Wechseln zu: Navigation, Suche


1. Textverarbeitung

Die Verarbeitung von Texten ist die klassische Anwendung für Computer. Ursprünglich war ihr Einsatz mit der Hoffnung verbunden auf Papier ganz verzichten zu können, bisher hat der Papierverbrauch aber eher zugenommen. Der große Vorteil der Textverarbeitung besteht darin, dass Texte sehr leicht überarbeitet und ganze Passagen umgestellt werden können. Wer einmal ein mehrseitiges Manuskript nur deshalb auf der Schreibmaschine vollständig neu tippen musste, weil er Textteile umstellen wollte, der weiß den Vorteil zu schätzen.

1.1 Werkzeuge

Video Video: Textverarbeitung im Editor (2 Teile 1,5 und 1,6 MB, Flash-Format, Sprecher: Detlef Rick)

Im Prinzip kann man seine Texte mit einem einfachen Texteditor wie dem Programm Editor von Windows oder KWrite unter Linux erstellen. Eine moderne Textverarbeitung leistet deutlich mehr. Sie erlaubt das Einbinden von grafischen Elementen und hilft beim Gliedern des Dokumentes sowie der Textgestaltung. Fast alle aktuellen Programme arbeiten heute nach dem Prinzip What You See Is What You Get („Was du siehst, ist, was du bekommst“) kurz WYSIWYG. Man sieht hier schon beim Bearbeiten am Bildschirm, wie der Text später im Ausdruck aussehen wird. WYSIWYG hat aber nicht nur Vorteile, Inhalt und Gestaltung werden oft nicht mehr sauber getrennt.

Alle Office-Pakete verfügen über eine entsprechende Textverarbeitungs-Komponente, weit verbreitete Pakete sind WordPerfect-Office, Microsoft Office und OpenOffice.

In der Aufzählung fehlt eigentlich noch StarOffice, das Paket aus dem Hause SUN. Bei StarOffice handelt es sich aber lediglich um die kommerzielle Version von OpenOffice. Die beiden Pakete unterscheiden sich nicht im Programmcode, sondern nur in den zusätzlichen Komponenten wie Rechtschreibüberprüfung, Thesaurus und Clip-Art Sammlung. OpenOffice ist vollkommen kostenlos unter der Adresse http://de.openoffice.org zum Download verfügbar.

1.2 Für Umsteiger

Video Video: Writer - Installation (2 Teile 2,1 und 2,2 MB, Flash-Format, Sprecher: Detlef Rick)

Auch wenn Sie bisher mit einer anderen Textverarbeitung gearbeitet haben, wird Ihnen die Umstellung auf OpenOffice Writer kaum Probleme bereiten. Das Programm verfügt über eine große Anzahl von Filtern für den Import und den Export von Dokumenten aus anderen Anwendungen. Unterstützt werden z.B. WordPerfect und verschiedene Word-Versionen.

2. Writer

Video Video: Writer - der erste Start (2,9 MB, Flash-Format, Sprecher: Detlef Rick)

Der Name ist Programm, die Textverarbeitung aus dem OpenOffice-Paket nennt sich ganz schlicht Writer. Dahinter steckt eine Textverarbeitung, die auch für den schulischen Einsatz gut geeignet ist.


2.1 Die Arbeitsoberfläche

Video Video: Writer - die Oberfläche (2 Videos 2,1 und 1,5 MB, Flash-Format, Sprecher: Detlef Rick)

Die Arbeitsoberfläche von Writer ist nicht ungewöhnlich, die meisten Elemente finden sich heute in allen grafischen Anwendungen so oder ähnlich.

Ooleisten.png

Writer verfügt in der Standard-Einstellung über verschiedene Symbolleisten.

  • Funktionsleiste
  • Objektleiste
  • Lineal
  • Statusleiste

Dazu kommen ggf. auch noch die Bildlaufleisten und natürlich die Menüleiste über die alle grafischen Anwendungen verfügen. Über die Menüleiste sind alle Funktionen erreichbar, die folgenden Beschreibungen benutzen aber soweit möglich den Weg über die Symbolleisten. Welche der Symbol-Leisten aktuell sichtbar sind hängt vom Arbeits-Kontext ab. Über den Menüpunkt Ansicht -> Symbolleisten besteht zusätzlich die Möglichkeit die Leisten und ihre Darstellung zu Konfigurieren.

2.2 Funktionsleiste

Direkt unterhalb der Menüleiste finden Sie die Funktionsleiste. Hier sind die Funktionen untergebracht, die sich auf das Dokument als Ganzes beziehen.

Writer-funktionsleiste.PNG

Dazu gehören Neu, Öffnen, Speichern und Drucken. Und natürlich auch Ausschneiden, Kopieren und Einfügen. Diese Leiste ist in allen Komponenten von OpenOffice vorhanden und hat auch immer fast den gleichen Aufbau.

Im rechten Teil der Leiste, nach den Pfeilen für Rückgängig bzw. Wiederherstellen finden sich Funktionen, die für die Komponente spezifisch sind. Sie werden einige der Funktionen noch kennen lernen. Etwas ungewöhnlich ist noch Zeichenfunktionen anzeigen, symbolisiert durch einen Stift. Aktiviert man diese Funktion, so erscheint eine weitere Leiste unten am Bildschirm direkt zwischen der Bildlaufleiste und der Statusleiste, die Leiste Zeichenfunktionen.

Writer-zeichenfunktionen.PNG

Über diese Leiste besteht die Möglichkeit Elemente wie Rechtecke, Linien, Smileys und Pfeile in die Textdokumente zu integrieren.


2.3 Objektleiste

Die zweite Leiste von Oben ist die Objektleiste, die es in ähnlicher Form für jede Programmkomponente gibt. Da es innerhalb einer Textverarbeitung verschiedene Arten von Objekten gibt existieren auch verschiedene Objektleisten.

Wenn kein Objekt oder ein Textobjekt markiert ist, dann ist die Textobjekt-Leiste zu sehen.

Writer-objektleiste.PNG

Hier finden sich die Funktionen, die zur Gestaltung von Texten notwendig sind. Hinter vielen Icons stecken Auswahllisten, die jeweils über einen Klick auf das kleine Dreieck rechts daneben aufklappen. Leider sind die Funktionen hier nicht nach der Art der Objekte gegliedert auf die sie sich beziehen, sondern eher nach Kompatibilität mit den Textverarbeitungen anderer Hersteller.

Auf Text-Objekte vom Typ Zeichen, also Buchstaben, beziehen sich hier die Funktionen

  • Schriftname
  • Schriftgröße
  • Fett
  • Kursiv
  • Unterstrichen
  • Zeichenfarbe
  • Zeichenhintergrund

Auf Text-Objekte vom Typ Absatz beziehen sich die Funktionen

  • Vorlage anwenden
  • Linksbündig
  • Zentriert
  • Rechtsbündig
  • Blocksatz
  • Nummerierung an/aus
  • Aufzählungsliste an/aus
  • Einzug vermindern
    Writer-vorlagen.PNG
  • Einzug erhöhen

Auf den gesamten Textbereich bezieht sich die Funktion Hintergrundfarbe. Etwas heraus fällt auch die erste Funktion Formatvorlagen. Hier stehen die Vorlagen für alle Typen von Text-Objekten zur Verfügung, z.B. für Zeichen, Absätze und ganze Seiten.

Vorlagen sind eine zu wenig beachtete Möglichkeit den Inhalt eines Textes von der konkreten Gestaltung zu trennen. Um z.B. einen Absatz als Überschrift auszuzeichnen bringt man nicht seine Zeichen nicht in eine bestimmte Schriftart und Schriftgröße, sondern man weist ihm z.B. die Absatz-Vorlage Überschrift zu. In welcher Schriftart und Schriftgröße solche Absätze dann erscheinen wird über die Vorlage eingestellt.

Falls im Dokument etwas markiert wird, was kein Text-Objekt, sondern ein Grafik-Objekt ist, so verändert sich die Objekt-Leiste entsprechend.

Writer-objektleiste2.PNG

Hier sind vor allem die Funktionen vorhanden, die die Ausrichtung der Grafik und ihre Anordnung zum Text betreffen.

Wichtig ist auch noch eine weitere Art von Objekten, die Zeichnungs-Objekte. Das sind die Objekte, die mit den Zeichnungs-Funktionen erstellt wurden. Auch für diese Objekte gibt es eine eigene Objekt-Leiste.

Writer-objektleiste3.PNG

Hier geht es vor allem um die Gestaltung der Rand-Linien und der Fläche.

2.4 Lineal

Das Lineal bzw. die Lineale, es gibt nämlich sowohl ein horizontales, als auch ein vertikales Exemplar dienen dazu Elemente im Dokument genau zu positionieren.

Writer-lineal.PNG

Writer-lineal2.PNG
Zusätzlich kann man über die Lineale auch eine Vielzahl von Einstellungen vornehmen.

Geht man in einem Lineal mit der Maus auf auf die Grenzlinie zwischen dem grau hinterlegten Randbereich und dem weiß hinterlegten Seitenbereich, so kann man diese Linie und damit die Seitenränder verschieben.

Das horizontale Lineal verfügt zusätzlich über verschiebbare Reiter für die Absatzeinzüge. Das sind die grauen Dreiecke deren Spitze nach Oben zeigt. Am linken Rand gibt es zusätzlich ein graues Dreieck mit der Spitze nach Unten. Damit lässt sich der Einzug der ersten Zeile eines Absatzes getrennt einstellen. Alle hier vorgenommenen Einstellungen wirken auf den aktuellen Absatz bzw. alle markierten Absätze.

Im horizontalen Lineal finden sich alle 1,25cm zusätzlich Markierungen, die wie ein auf dem Kopf stehendes "T" aussehen. Es handelt sich hierbei um Tabulator-Marken, die beim Ausrichten von Text helfen, ein Druck auf die Tabulator-Taste führt zum Sprung zur nächsten Markierung. Auch diese Markierungen lassen sich mit der Maus verschieben, mit einem Doppelklick auf eines der Zeichen lassen sich weitere Eigenschaften einstellen. Die Tabulator-Einstellungen betreffen nur den aktuellen Absatz.

2.5 Statusleiste

Die unterste Leiste des OpenOffice-Fensters wird leicht übersehen, dabei beinhaltet sie eine Reihe von nützlichen Informationen.

Writer-statusleiste.PNG

Die Leiste gliedert sich in mehrere Felder.

  • Im ersten Feld sehen Sie, auf welcher Seite des Dokumentes Sie Sich befinden und wieviele Seiten zu dem Dokument gehören. Ein Doppelklick auf das Feld startet den Navigator, über den Sie Sich innerhalb des Dokumentes orientieren können.
  • Im zweiten Feld zeigt Writer die gewählte Seiten-Vorlage an. Mit einem Klick der rechten Maustaste öffnet sich eine Auswahlliste der verfügbaren Seiten-Formate, mit einem Doppelklick mit der linken Maustaste erscheint das Menü zum Bearbeiten von Vorlagen.
  • Im dritten Feld sehen Sie den Ansichtsmaßstab, den Sie über einen Doppelklick in dieses Feld ändern können.
  • Das vierte Feld zeigt den Status der Taste Einfg an. Ist hier EINFG zu lesen, dann ist der Status Einfügen, beim Status Überschreiben steht hier ÜBER. Zusätzlich verändert sich beim Umstellen auch das Aussehen der Schreibmarke, des Cursors. Im Modus Einfügen ist er ein schmaler Strich zwischen zwei Buchstaben, alle Eingaben erfolgen zwischen diese Buchstaben. Im Überschreiben-Modus liegt er als Rechteck hinter einem Buchstaben, der dann durch eine Eingabe überschrieben würde.
  • Das fünfte Feld zeigt den aktuellen Auswahlmodus an. Er kann durch einen Mausklick zwischen Standard (STD), Erweitern (ER) und Ergänzen (ERG) umgestellt werden.
  • Im sechsten Feld kann man mit einem Mausklick zwischen HYP und SEL umstellen. Das verändert die Art und Weise, wie Writer auf einen Mausklick in Hyperlinks reagiert. Bei der Einstellung HYP sind die Links aktiv, es würde also die entsprechende Seite geladen werden, im Modus SEL kann man die Links bearbeiten da sie dann nicht aktiv sind.
  • Ein Stern im siebten Feld weist darauf hin, dass das Dokument seit der letzten Änderung noch nicht wieder gespeichert wurde.
  • Eventuell vorhandene digitale Signaturen werden im achten Feld angezeigt.
  • Das neunte, recht große Feld, dient zur Anzeige verschiedener Informationen. Ist ein grafisches Element ausgewählt, so steht hier dessen Position und Größe. Ein Doppelklick auf dieses Feld hat unterschiedliche Auswirkungen. Bei grafischen Elementen öffnet sich der Dialog Position und Größe, ansonsten der Dialog Feldbefehle.

2.6 Writer und seine Leisten

Writer-leisten.PNG
Bisher war schon von einer Vielzahl von Leisten die Rede. Bei einer bereits benutzten Writer-Version kann die Anordnung der Leisten von der Beschreibung abweichen. Generell kann man bei OpenOffice Leisten fast immer aus ihrer Verankerung lösen, aber auch an anderen Stellen wieder andocken. Damit lässt sich die Arbeitsumgebung an die eigenen Bedürfnisse anpassen.

Nehmen wir als Beispiel einmal die bereits beschriebene Symbolleiste Zeichnen, die sich normalerweise direkt oberhalb der Statuszeile befindet. Zum Aktivieren der Zeile klickt man auf Zeichenfunktionen anzeigen in der Funktionsleiste oder auf Ansicht -> Symbolleiste -> Zeichnen im Menü.

Wenn man sich die Abbildung z.B. der Objektleisten genau ansieht, dann fällt am Ende der Leiste ein kleines Dreieck auf. Klickt man darauf, so öffnet sich ein Dialog zum Bearbeiten von Menüs. Damit kann man auch festlegen, welche Knöpfe auf der jeweiligen Leiste erscheinen sollen.

Ganz vorne in der Leiste kann man eine Spalte von Punkten erkennen. Wenn man hier mit der Maus drauf klickt, dann kann man die Leiste mit weiter gedrückter Taste aus ihrer Position herausziehen. Man kann die Leiste dann frei verschieben und bei Bedarf wieder an einer der Bildschirm-Kanten andocken lassen. Die nebenstehende Abbildung zeigt eine Zeichnen-Leiste, die am linken Rand des Fensters angedockt wurde. Falls der eigene Bildschirm eine genügend große Auflösung besitzt kann man die Zeichnen-Leiste auch neben der Funktions-Leiste positionieren.


3. Dokumente erstellen mit Writer

Wenn man sinnvoll mit der Textverarbeitung arbeiten möchte, dann sollte man ein paar Dinge beachten. Generell sollte man sehr zurückhaltend mit den Gestaltungsmöglichkeiten der Programme umgehen. Also nicht unnötig viele Attribute auf einmal verändern, um den Leser nicht zu verwirren. Wenn man einen Textabschnitt dadurch hervorhebt, dass man ihn kursiv setzt, so sollte man ihn nicht auch noch unterstreichen.


3.1 Gliedern von Texten

Wichtig ist eine klare Gliederung des Dokumentes. Im Idealfall besteht ein Dokument aus einfachem Text und zwischendrin einigen Überschriften. Im einfachen Text sind dann einzelne Worte durch Attribute wie Fett oder Kursiv hervorgehoben.

In der folgenden Abbildung ist der Anfang des vorliegenden Textes zu sehen. Er besteht aus dem eigentlichen Text und drei unterschiedlichen Überschriften.

Writer-text1.PNG

Der erste Schritt zum Erstellen eines Textes wie in der Abbildung besteht darin den Text zu tippen und für die Überschriften erst einmal nur eigene Zeilen bzw. Absätze zu erstellen, indem man auf die Return-Taste drückt. Die Zeilenaufteilung des eigentlichen Fließtextes übernimmt Writer, man drückt nur dann auf die Return-Taste, wenn ein neuer Absatz beginnen soll.

Der eigentliche Text wird im vorgegebenen Absatz-Format Standard erstellt. Zum Formatieren der Überschriften bewegt man den Cursor in die erste Zeile und wählt dann über die Funktionsleiste das Absatzformat Überschrift1 aus. Ein Markieren des Textes ist nicht notwendig, da sich ein Absatz-Format immer auf den gesamten Absatz bezieht und der Absatz schon eindeutig dadurch gekennzeichnet ist, wenn sich der Cursor in ihm befindet.

Die nächste Überschrift ist eine Kapitel-Überschrift und daher vom Format Überschrift2, die dritte Überschrift ist eine Unterüberschrift und damit vom Typ Überschrift 3.

In dem Text sind einzelne Bereiche, wie z.B. die Langform von WYSIWYG kursiv gesetzt. Dazu muss man jetzt in der Regel den Bereich markieren und auf das entsprechende Icon in der Objekt-leiste klicken. Writer kann ja ohne die Markierung nicht wissen, welche Folge von Zeichen ich kursiv gestellt haben möchte.


3.2 Arbeiten mit Vorlagen

Writer bietet verschiedene Vorlagen zur Auswahl an. Falls man mit den vorgegebenen Einstellungen nicht zufrieden ist kann man entweder eigene Vorlagen erstellen oder die vorhandenen Vorlagen anpassen.

Soll z.B. eine Überschrift 2 zusätzlich noch über das Attribut Kursiv verfügen, so bewegt man den Cursor in eine Überschrift mit der entsprechenden Formatierung und klick auf das Icon Kursiv. Die eine Zeile ist also in ihrer Formatierung angepasst. Nun muss man die veränderte Einstellung in die Vorlage übernehmen. Dazu klicke man auf Formatvorlagen in der Objektleiste. Es öffnet sich das Fenster zur Auswahl der Formatvorlagen.

Vorlagen.png

Hier sollte Überschrift 2 hervorgehoben sein. Nun klickt man im Fenster Absatzvorlagen auf das Icon rechts oben und wählt aus der sich öffnenden Liste den Punkt Vorlage aktualisieren. Damit verändert sich sofort auch das Aussehen aller weiteren Überschriften dieser Kategorie.

Entsprechend kann man auch eigene Vorlagen erstellen, indem man einen Absatz wie gewünscht formatiert und dann im Dialog Absatzvorlagen Neue Vorlage aus Selektion anwählt. Nach der Eingabe eines Namens für die Vorlage steht diese zur Verfügung.


3.3 Rechtschreibung und Silbentrennung

Writer-korrektur.PNG
In der Abbildung sind einige Wörter rot unterstrichen. Hierbei handelt es sich um Hinweise der Rechtschreibüberprüfung, die z.B. das Wort Writer nicht kennt. Man kann falsch geschriebene Wörter entweder per Hand korrigieren oder mit der rechten Maustaste auf das unterstrichene Wort klicken. Writer macht dann Korrekturvorschläge, sofern vorhanden.

Die Rechtschreibüberprüfung muss man immer mit einer gewissen Vorsicht benutzen. Im Prinzip vergleichen die Programme immer nur wortweise die geschriebenen Wörter mit einem eingebauten Wörterbuch. Falls ein Wort wie z.B. Writer nicht in diesem Wörterbuch vorkommt wird es markiert. Umgekehrt kann die Rechtschreibüberprüfung einen Fehler nicht erkennen, wenn er zu einem Wort führt, welches im Wörterbuch vorkommt. Wer also z.B. Hund statt Hand tippt kann nicht auf die Hilfe der Software rechnen, auch wenn der entstandene Satz keinen Sinn ergibt.

Man kann das Wörterbuch von Writer auch erweitern. In dem Kontextmenü (mit der rechten Maustaste klicken) eines markierten Wortes taucht auch die Option Aufnehmen auf. Hierüber kann man einzelne Wörter oder Eigennamen in das Standard-Wörterbuch aufnehmen.

Beim Bereich What you... sollte man die Möglichkeit auszuwählen, dass es sich um Englische Wörter handelt.

Man kann natürlich auch die automatische Rechtschreibüberprüfung abschalten, dazu klickt man in der Funktionsleiste auf das Icon mit den rot unterstrichenen Buchtaben ABC.

Eine eng verwandte Funktion ist die Silbentrennung. Gerade bei Texten die im Blocksatz gestaltet sind oder sehr schmale Spalten bilden sieht es einfach besser aus, wenn die Zeilen möglichst gleichmäßig gefüllt sind.

Writer-silbentrennung.PNG
Die Silbentrennung startet man aus der Menüleiste heraus über den Menüpunkt Extras -> Sprache -> Silbentrennung. Writer beherrscht die Silbentrennung recht gut, möchte in der Standardeinstellung aber jeden Trennvorschlag bestätigt haben. Wenn das zu lästig wird kann man den Vorschlagsdialog für die Silbentrennung abzuschalten, im Menü unter Extras -> Optionen -> Spracheinstellungen -> Linguistik aktiviert man dazu das Markierfeld Trennen ohne Nachfrage.

Writer-silbentrennung2.PNG

Soll die Silbentrennung automatisch, schon bei der Eingabe, erfolgen so findet sich die entsprechende Einstellung unter Format -> Absatz -> Textfluss.

Writer-silbentrennung3.PNG

Da es sich hierbei um eine Absatz-Einstellung handelt wirkt sie sich immer nur auf den aktuellen Absatz aus, man wird in der Regel also vorher den gesamten Text markieren.

OpenOffice bietet die Möglichkeit Rechtschreibüberprüfung und Silbentrennung für nahezu beliebige Sprachen zusätzlich zu installieren. Dazu findet sich im Menü Datei -> Assistenten -> Weitere Wörterbücher installieren... ein Tool namens DicOOo. Es handelt sich dabei um ein geschütztes Textdokument mit eingebautem Makro.

Falls das Dokument nicht wie angegeben erreichbar ist kann man es von folgender Adresse laden: http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/dicooo/DicOOo.sxw. Eventuell muss vor dem Öffnen der Datei unter Extras → Optionen → Sicherheit → Makrosicherheit die Sicherheitsstufe auf Mittel gesetzt werden.

Im ersten Schritt wählt man die Sprache für die weitere Benutzerführung aus und klickt dann auf den Knopf Starte DicOOo. Nachdem die aktuelle Liste aus dem Internet geladen ist folgt eine Dialog zur Auswahl der vorhandenen Wörterbücher.

DicOOo1.png

Für viele Sprachen gibt es mehrere Versionen, die nationale Besonderheiten berücksichtigen. Neben dem Wörterbüch kann man dann auch die Wortliste für die Silbentrennung und den Thesaurus auf die gleiche Art installieren.

DicOOo.png

DicOOo warnt übrigens davor mehr als zehn Wörterbücher gleichzeitig zu installieren, weil sonst die Arbeitsgeschwindigkeit leidet.


3.4 Laden und Speichern von Texten

Writer-speichern1.PNG
Beim Erstellen von Texten kann man nicht früh genug daran denken den Text auch zu Speichern. Die entsprechende Funktion findet sich direkt in der Funktionsleiste hinter dem Icon mit der Diskette. Sofern es sich um den ersten Speichervorgang handelt fragt Writer den Dateinamen und den Dateityp ab.

Writer kann nicht nur im OpenDocument-Text Format (ODT) speichern, sondern auch in vielen fremden Datei-Formaten wie verschiedenen Word-Formaten (DOC), dem RichText Format (RTF) und auch im einfachen Text-Format (TXT). Generell sollte man möglichst im OpenDocument-Format speichern, die Dateien sind deutlich kleiner als vergleichbare Dokumente im Word-Format. Die Formate, die Writer schreiben kann, kann er auch wieder einlesen. Die Probleme beim Datenaustausch zwischen OpenOffice und Word sind in der Regel geringer als beim Austausch zwischen verschiedenen Word-Versionen.

Zusätzlich verfügt Writer über eine Export-Funktion für PDF-Dokumente. Das entsprechende Icon befindet sich ebenfalls in der Funktionleiste. Beim Portable Document Format (PDF) handelt es sich um ein plattformübergreifendes Dateiformat, welches für die Weitergabe von gestalteten Dokumenten ideal ist. Ein PDF-Dokument lässt sich auf nahezu jedem Rechner Betrachten und Drucken uns sieht dabei immer gleich aus. Eine weitere Bearbeitung von PDF-Dokumenten ist aber nur mit speziellen Programmen möglich.

Sollte Writer einmal abstürzen, bevor das aktuelle Dokument gespeichert ist, so hat man trotzdem eine gute Chance ohne große Verluste zu bleiben. In der Voreinstellung erstellt Writer alle 15 Minuten Daten zu Wiederherstellung. Beim nächsten Start stellt das Programm die Dokumente dann automatisch wieder her. Falls 15 Minuten zu lang sind kann man die Zeit verändern. Über das Menü Extras -> Optionen kommt man an die entsprechenden Einstellungen heran.

Writer-optionen.PNG

Normalerweise ist der Zeitraum von 15 Minuten aber sinnvoll gewählt.

3.5 Grafiken einbinden

Texte ohne auflockernde Grafiken sind heute eher unüblich. Für das Einbinden von grafischen Elementen gibt es in Writer verschiedene Möglichkeiten. Am einfachsten ist hierbei das Einbinden einer Abbildung, die als Datei auf der Festplatte vorhanden ist.

Dazu klickt man auf das Icon Aus Datei in der Zeichnen Leiste oder geht über das Menü Einfügen -> Bild -> Aus Datei. Daraufhin öffnet sich ein Datei-Dialog des jeweiligen Betriebssystems. Hier wählt man die gewünschte Datei, sowie man dann auf Öffnen klickt bindet Writer sie ein. Sofern die Abbildung groß genug ist steht ihr die komplette Seiten-Breite zur Verfügung.

Falls man die Abbildung direkt in den Text integrieren möchte klickt man mit der rechten Maustaste auf die Abbildung und wählt Bild... aus dem Kontextmenü.

Writer-abbildung1.PNG

Bevor man hier aber die Größenangaben verändert sollte man unbedingt ein Häkchen im Feld Abgleich setzen, damit die Abbildung nicht verzerrt wird. So langt es auch eine der Angaben, vorzugsweise die Breite zu ändern. Wählt man dann für die Horizontale Position noch Rechts, dann steht für den Text Platz zur Verfügung.

Writer-abbildung2.PNG

Der Text würde die Abbildung aber noch nicht umfließen, da das im Reiter Umlauf erst noch erlaubt werden muss. Die Standardeinstellung ist Kein. Erst wenn man hier Vor auswählt ergibt sich die gewünschte Darstellung.

Writer-abbildung3.PNG

Eine weitere mögliche Quelle für Abbildungen ist die Gallery, die über einen Klick auf das Icon in der Funktionsleiste zu öffnen ist. Die hier vorhandenen Grafiken können einfach in das Text-Dokument hinein gezogen werden. Leider liefert OpenOffice nur wenige Grafiken mit, Benutzer von StarOffice haben da deutlich mehr Auswahl. Zwar können auch OpenOffice-Benutzer leicht freie Clipart-Bibliotheken installieren, das geht aber über den Rahmen dieser Einführung hinaus.

Weitere Möglichkeiten bietet die Zeichnen-Leiste. Hier stehen einfache Objekte wie Linien, Pfeile und Smileys zur Verfügung, die einfach über die vorhandenen Elemente gelegt werden können.

Writer-abbildung4.PNG

Vorsicht vor der Zwischenablage: Ein auf den ersten Blick sehr praktischer Weg zum Einbinden von Abbildungen aus Webseiten oder anderen Dokumenten ist die Zwischenablage. Hier würde man z.B. im Browser mit der rechten Maustaste auf die Abbildung klicken und aus dem Kontextmenü Kopieren wählen. In der Textverarbeitung kann man das Bild dann über den Menüpunkt Einfügen einbinden. Dabei muss die Abbildung aber umgewandelt werden, in ein für die Zwischenablage brauchbares Format. Dadurch kann die Textdatei wesentlich größer werden, als beim Weg über Grafik Speichern unter... im Browser und anschließendem Einfügen -> Bild -> Aus Datei... in Writer. Mit der JPG-Abbildung Nachlass.jpg aus dem Text zur Digitalisiertung ergibt sich beim Einfügen über die Windows-Zwischenablage eine Dateigröße von 450 kByte (bei Word sogar 540 kByte) und beim Weg über Speichern und Laden nur 181 kByte.


4. Besondere Funktionen in Writer

In vielen Dokumenten zur Einführung in die Textverarbeitung finden sich Beschreibungen wie man Serienbriefe erstellt, auf Datenbanken zugreift oder Kalkulationstabellen einfügt. Im schulischen Alltag braucht man diese Funktionen aber selten.

In diesem Abschnitt finden sich Funktionen, die in der Schule eher Anwendung finden könnten.


4.1 FontWork

Oftmals möchte man auf der Titelseite von Dokumenten die Überschrift in besonderer Form grafisch gestalten. Dazu besitzt Writer im Menü Format -> Objekt den Menüpunkt Fontwork. Dieser Menüpunkt ist normalerweise deaktiviert, auch dann wenn Text markiert wurde.

Als Grundlage für Fontwork dient Text, den man über die Funktion Text der Zeichenleiste erstellt hat. Klickt man auf diese Funktion, so kann man mit der Maus auf der Seite einen Bereich aufziehen, in den man dann Text eingeben kann. Solange dieser Bereich aktiv ist steht der Menüpunkt Format -> Objekt -> Fontwork zur Verfügung. Aktiviert man ihn, so erscheint die Fontwork-Leiste.

Fontwork1.png

Sowie man auf eine der Linien-Formen im oberen Bereich der Leiste klickt wird der Text in die entsprechende Form gebracht. Mit den weiteren Elementen dieser Leiste kann man Einfluss auf die Anordnung und Ausrichtung der einzelnen Buchstaben nehmen und auch Schatteneffekte einstellen. Wenn man dann noch mit den Farbeinstellungen für grafische Elemente etwas spielt lassen sich ansprechende Schmucktexte erstellen.

Vermutlich erschien den Programm-Autoren von Writer der Umgang mit den Möglichkeiten der Fontwork-Funktion zu kompliziert. Jedenfalls gibt es im Programm eine weitere Funktionalität, die zu ähnlichen Ergebnissen führt. In der Objektleiste Zeichnen gibt es einen Menüpunkt FontworkGallery. Wählt man diesen an, so erscheint ein Auswahlfenster mit einer Vielzahl von möglichen Gestaltungen.

Fontwork2.png

Wählt man eine der Vorgaben aus, so erscheint das entsprechende Grafikobjekt im Dokument. Den Text, vorgegeben ist Fontwork, kann man nach einem Doppelklick auf das Element bearbeiten.

Solange das Fontwork Objekt markiert, also aktiv ist sollte auch die zugehörige Fontwork-Leiste vorhanden sein. Sollte diese fehlen, so kann man sie über Ansicht -> Symbolleisten -> Fontwork nachträglich sichtbar machen.

Fontwork3.png

Bis hierher entspricht diese Funktion der eingangs beschriebenen Fontwork-Funktion nur mit dem Unterschied, dass schon Farb- und Schatteneffekte vorgegeben sind. Es gibt aber noch eine wirklich interessante zusätzliche Möglichkeit. Wenn das Fontwork-Objekt aktiv ist kann man in der Zeichnen-Leiste das Icon Extrusion ein/aus aktivieren. Damit bekommt das Element einen räumlichen Effekt, der sich über die zusätzliche Leiste 3D-Einstellungen noch weiter konfigurieren lässt.

Fontwork4.png

Generell kann man fast alle Elementen aus der Zeichnen-Leiste per Extrusion zu einem 3D-Effekt verhelfen. Der Begriff Extrusion beschreibt dabei einen Vorgang, bei dem ein Objekt durch Spritzen aus einer Düse entsteht, ähnlich wie die Figuren die man mit einem Spritzbeutel aus Sahne erstellen kann. Das zweidimensionale Objekt beschreibt dabei die Form der Düse.

4.2 Formelgenerator

In einem Text tauchen häufiger einmal Formeln auf, auch wenn es eventuell nur einfach Brüche sind. Das Erstellen von Formeln ist mit der eigentlichen Textverarbeitung nicht ganz einfach. Zum Glück verfügt Writer über einen Formelgenerator, der das Erstellen solcher Ausdrücke deutlich vereinfacht.

Zum Erstellen einer Formel geht man im Menü auf Einfügen -> Objekt -> Formel. Der Bildschirm teilt sich und eine zusätzliche Leiste erscheint, die Auswahl-Leiste. Sollte die Leiste nicht erscheinen, so kann man sie über Ansicht -> Auswahl aktivieren.

Formel1.png

In der Auswahl-Leiste finden sich im oberen Bereich die Rubriken, aktive ist die Rubrik Operatoren und im unteren Bereich die jeweiligen Funktionen. Klickt man hier auf Bruch, so ergibt sich die Darstellung aus der Abbildung. Im oberen Bereich des Fensters sieht man eine grafische Vorschau und im unteren Bereich eine Umschreibung der Formel, die man editieren kann und auch muss.

In der Vorgabe steht hier

{<?>} over {<?>}

Writer weiß ja nicht was im Zähler bzw. Nenner des Bruches stehen soll. Ersetzt man die Platzhalter durch entsprechende Ziffern, so entsteht die gewünschte Formel im oberen Bereich.

Formel2.png
Gibt man
3+4 over 5 

ein, so ergibt sich die nebenstehende Formel.

Formel3.png
Soll 3+4 im Zähler des Bruches stehen, so muss man Klammern setzen. Die geschweiften Klammern bleiben dabei in der Formel unsichtbar.
{3+4} over 5

ergibt dann also eine andere Darstellung.

Mit Writer lassen sich so recht einfach auch aufwändige Formeln gestalten.

4.3 Flyer

Sehr häufig kann man für Einladungen oder Ähnliches Klapp-Karten im DIN A6 Format gebrauchen, die auf allen vier Seiten beschrieben sind. Eine solche Karte kann man sich recht einfach aus einem einseitig bedruckten DIN A4 Blatt erstellen. Dazu faltet man das Blatt zweimal, indem man zuerst einmal die Höhe halbiert, dann das kleinere Blatt um 90° dreht und dann erneut die Höhe halbiert. Es entsteht eine Klappkarte im Format DIN A6.

Beschriftet man die vier Seiten nun der Reihe nach mit den Nummern 1 bis 4, so ergibt sich beim Aufklappen folgendes Bild.

Flyer1.png

Will man ein solches vierseitiges Dokument erstellen, so ist die Seitenreihenfolge also 4-1-3-2, wobei die Seiten 3 und 2 auf dem Kopf stehen müssen.

In Writer lässt sich ein solches Dokument recht einfach erzeugen. Man kümmert sich dazu nicht um das eigentliche Seitenformat DIN A6, sonder erstellt alle vier Seiten im normalen Seitenformat, achtet aber auf die Reihenfolge und darauf alle Elemente etwas größer zu halten, damit sie später auch in der kleineren Darstellung gue zu erkennen sind.

Die Seiten 4 und 1 sollten dabei kein Problem sein, man muss nur auf die richtige Reihenfolge achten. Alle Elemente der Seiten 3 und 2 müssen aber auf dem Kopf stehen. Das ist für grafische Elemente keine Problem. Bei denen stehen einem schon in der Bild-Leiste Funktionen zum horizontalen und vertikalen Spiegeln zur Verfügung.

Flyer2.png

Wendet man beide Spiegelungen nacheinander an, so entspricht das der gewünschten Drehung um 180°.

Mit normalem Text ist ein Drehen oder Spiegeln nicht möglich. Das ist aber kein Problem, man wählt einfach die Funktion Text aus der Zeichnen-Leiste. Den gewünschten Text gibt man dann in den Text-Rahmen ein.

Nach Abschluss der Texteingabe steht im Kontextmenü (mit der rechten Maustaste auf das Objekt klicken) unter Position und Größe der Reiter Drehung zur Verfügung. Hier gibt man als Drehwinkel 180° an und hat den gewünschten Effekt erzielt.

Hat man die vier Seiten in der richtigen Reihenfolge und Orientierung erstellt, so muss man sich nur noch alle gleichzeitig auf eine DIN A4 Seite drucken.

Dazu geht man im Menü Datei auf den Menüpunkt Seitenansicht. Dort kann man in der Objektleiste Seitenvorschau unter Seitenansicht: mehrere Seiten auf zwei Zeilen und zwei Spalten einstellen. Wichtiger ist aber die Einstellung unter Druckoptionen Seitenansicht.

Flyer3.png

Hier stellt man man auf zwei Zeilen und zwei Spalten ein. Wenn man jetzt über Seitenansicht Drucken den Druck veranlasst werden die Seiten wie geplant auf das Papier gebracht.